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1 OVERVIEW 

This Manual will focus on configuring Kenwood NEXEDGE NX-7xx/8xx Radios with the RadioPro System. 

Please Refer to the RadioPro IP Gateway Installation Guide for general installation information relevant for all radio 

system types. 

1.1 System Planner Template 

Use the System Planner Template on page 27 of this document in the planning phase of a project to record IP addresses, 

usernames, passwords, serial numbers, and device names. 

1.2 Required Items 

1.2.1 Radio Interface Cable 

A radio interface cable must be ordered for each IP Gateway from the following table: 

Control Station Radio Cable Part # 

Kenwood NEXEDGE NX-700/800/5700/5800 S2-61769 

Kenwood NEXEDGE NX-720/820 S2-61890 

Other cables are available to connect a dedicated data revert radio.  Contact CTI for more information. 

1.2.2 Control Station Radio 

Each Control Station radio used for voice requires one IP Gateway.  The control station radio connected to the IP 

Gateway must at least have the minimum firmware version listed below.  Kenwood’s FPU (Field Programming 

Unit) software will be needed to configure the control station radio. 

Control Station Radio 
Minimum 
Version 

Programming 
Software 

Kenwood NEXEDGE NX-700/800 or NX-720/820 3.21.00 KPG-111DN 

Kenwood NEXEDGE NX-5700/5800 2.31.00 KPG-D1N 

1.2.3 Radio Programming Cable 

A radio programming cable is required to configure the Control Station radio.   

Note:  A programming cable connected to the front microphone connector on the Control Station radio may 

prevent communications to a RadioPro IP Gateway from the Rear Accessory Connector.  Therefore, when a cable 

is connected to the Rear Accessory Connector to connect a RadioPro IP Gateway or a PC (during 

programming), ensure that the programming cable has been disconnected from the front microphone 

connector.   

https://ctiproducts.com/documents/radiopro/RadioPro%20IP%20Gateway%20Installation%20Guide.pdf
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2. FEATURE AVAILABILITY 

Kenwood NEXEDGE Systems 

Depending on NEXEDGE System Type, some features may not be available.  Use the following table to determine if a 

feature discussed in this document is available. 

 

    System Type 

 

Feature 
Analog  

Analog w/ 

FleetSync 

Digital 

NXDN 

Digital 

NXDN 

w/ call ack. 

  

NXDN 

& LTR 

Trunking 

NXDN 

Trunking 

(MsgTrnkd) 

Voice 

Dispatch 
✓ ✓ ✓ ✓ ✓ ✓ 

Text 

Messaging 
- ✓ ✓ ✓ ✓ ✓ 

GPS 

Mapping 
- ✓ ✓ ✓ ✓ ✓ 

Status 

Updates 
- ✓ ✓ ✓ ✓ ✓ 

Selective 

Calling 
- ✓ ✓ 

Not 

Currently 

Supported 
✓ 

Not 

Currently 

Supporte

d 

Remote 

Monitor 
- ✓ ✓ ✓ ✓ ✓ 

Remote 

Enable/Disa

ble 

- ✓ ✓ ✓ ✓ ✓ 
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3. CONFIGURATION AND INSTALLATION 

Use the steps in the following table to install a RadioPro System.  Each step is discussed in detail starting on Page 6. 

Following installation of the IP Gateway in Step 5, at least one Client must be installed from Step 6. 

 

Step # Description Kenwood NEXEDGE NX-7xx/8xx 

3.1.1 

Configure Control Station Radio(s) for Voice page 6 
 

3.1.2 

Configure Control Station Radio(s) for Data page 14 
 

3.1.3 

Configure Subscriber Radios for ARS, GPS, and TMS page 15 
 

3.2 

Connect RadioPro IP Gateway to Control Station Radio page 22 
 

3.3 

Configure RadioPro IP Gateway(s) using ICU.exe page 23 
 

 

Please Refer to the RadioPro IP Gateway Installation Guide for additional installation steps relevant for all radio 

system types. 

 

3.1 Program the Control Station Radio 

3.1.1 Configure the Voice Radio 
 

 

(For NX-5700/5800 radios see document # S2-61905.) 

Radio models NX-700/800 or NX-720/820 can be used as a control station radio. The use of an NX-720/820 requires 

modification to the option jumpers located on the radio’s Tx/Rx unit.  Therefore, the NX-700/800 is easier to implement 

since it does not require internal modifications. See Appendix - Radio Interface Cables for more details. 

Use the KPG-111DN FPU (Kenwood’s NEXEDGE ‘Field Programming Utility’ configuration software for NX-

7x0/8x0 radios) to configure NEXEDGE radio parameters using the following steps.  

https://ctiproducts.com/documents/radiopro/RadioPro%20IP%20Gateway%20Installation%20Guide.pdf
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1. Configure the control station as any other radio 

a. Using a Kenwood programming cable, connect the NX-700/800 Control Station radio to a PC or Notebook 

that has the correct Kenwood FPU version (KPG-111DN in this case). 

b. Open the KPG-111DN FPU. 

c. Ensure that the correct COM port is selected by going to the Setup > COM Port menu. 

d. Then, from the Program menu, select Read Data from the Transceiver as shown below. 

e. After the data has been read, use File > Import to load all of the previously saved settings required for the 

radio system.  Parameters may also be entered manually. 
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2. Configure the Data Port 

a. Open the Option Features 1 settings window using the menu commands:  

Edit > Optional Features > Optional Features 1.  

b. Select the Common Page 3 tab, and then under the Function column for COM port 1 in the table as 

shown below, select Data + GPS Data Output. 

c. For the PC Interface Protocol parameter, select Version 2.  

 Note: Selecting “Version 1” will prevent the IP Gateway from functioning properly. 

 

d. Select the Common Page 4 tab. 

i. Enable Stack options Short Message Stack, Latest Received Message Stack, and 

Message Memory by changing them to Checked. 

ii. Enable all of the options for both the Serial Output and Serial Input groups by changing 

them all to Checked. 
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3. Configure Sound Options 

a. Open the Extended Function window by using the menu commands: Edit > Extended Function.  

b. In the Modulation Line tab, MI2 column, and Mic PTT row, select Connect from the drop-down list as 

shown below. 

 

 

 

c. In the AUX tab, for Mic Sense, select 4dB (High) as shown below.  
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d. In the Mobile Function tab, for DEO Level (the level coming into the computer), select +5 as shown 

below. For either DI or DEO sound settings, levels may be adjusted as needed. 

 

 

 

4. Configure FleetSync settings 

Note:  Even if the radio is being used in analog mode without FleetSync, or in digital mode with NXDN, a 

FleetSync ID must be assigned.  Not entering an ID will prevent RadioPro from functioning properly. 

a. Open the FleetSync window by using the menu commands: Edit > FleetSync 

b. In the General 1 tab, enter a value for Fleet (Own) and ID (Own). (Note: These do not have to be used 

elsewhere, but they must have an assigned value.) 
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5. Configure NXDN settings 

Note:  Even if the radio is being used in analog mode without FleetSync, a FleetSync ID must be assigned.  

Not entering an ID will prevent RadioPro from functioning properly. 

a. Open the NXDN window by using the menu commands: Edit > NXDN 

b. In the General 1 tab, enter a value for Unit ID (Own).  

 

 

6. Configure Data settings 

a. For each zone listed in the Zone Information window, use the Zone Edit button to open the Zone Edit 
window. 
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b. Specify the channel to use for data by assigning the Data Zone-CH/GID (Analog) and Data Zone-
CH/GID (Digital) fields as required for your system. 

 

i. If using FleetSync in a conventional (non-trunked) system, ensure that the correct data will be 

sent to the Data Channel: 

- Open the FleetSync window by using the menu commands: Edit > FleetSync 

- In the Parameter tab, enable the desired message types to send across the Data Zone-
CH/GID with a Check. 
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ii. If using NXDN in a conventional system, ensure the correct data will be sent to the Data Channel.  

- Open the NXDN window by using the menu commands: Edit > NXDN 

- In the Conventional tab, enable the desired messages to send across the Data Zone-
CH/GID with a Check. 

 

7. Configure GPS settings 

In order for RadioPro to process GPS information from subscriber radios, the control station radio must know what 

data to send to the IP Gateway. 

a. Open the Optional Features 2 window by using the menu commands: Edit > Optional Features 2 

b. In the GPS tab, Base Station Settings section, enable the option for $PKLDS/$PKNDS (KW) with a 

Check. 

Note: Not selecting this option will result in GPS data not being sent to the RadioPro IP Gateway.  
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3.1.2 Configure the Data Revert Radio 

 

If you are using a Data Revert radio, follow the same steps for configuring the radio as you would for the Voice Radio 

with the following exceptions: 

• Because the Data Revert Radio does not deal with audio, you may skip the steps on page 9 for Configure 

Sound Options.  

• Because the Data Revert Radio will only receive GPS data, you may skip the steps on page 11 for 

Configure Data settings.   

• Be certain to follow steps described on page 13, Configure GPS Settings. 

• Because Channel Steering only affects the Voice Radio, program only the data channel into the radio. 
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3.1.3 Configure the Subscriber Radios 
 

 

Use the FPU (Kenwood’s NEXEDGE ‘Field Programming Utility’ configuration software) to configure NEXEDGE 

radio parameters using the following steps.  

1. Configure the subscriber radio as any other radio. 

a. Using a Kenwood programming cable, connect the NX-700/800 Control Station radio to a PC or Notebook 

that has the correct Kenwood FPU version (KPG-111DN in this case). 

b. Open the KPG-111DN FPU. 

c. Ensure that the correct COM port is selected by going to the Setup > COM port menu. 

d. Then, from the Program menu, select Read Data from the Transceiver as shown below. 

e. After the data has been read, use File > Import to load all of the previously saved settings required for 

your radio system.  Parameters may also be entered manually. 
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2. Configure Target/Base ID settings. 

a. If using FleetSync, ensure that the Target Fleet and Target ID specify the Control Station radio using 

the following steps: 

i. Open the FleetSync window by using the menu commands: Edit > FleetSync 

ii. In the Target tab, enter a value for Target Fleet and Target ID.  

Note: If the target does not include the Control Station(s), data will not appear in RadioPro. 

 

b. If using NXDN, ensure the Base ID specifies the Control Station radio using the following steps:  

i. Open the NXDN window by using the menu commands: Edit > NXDN 

ii. In the General 1 tab, enter a value for Base ID Type and Base ID. 

Note: If the Base ID does not include the Control Station(s), data will not be sent to 

RadioPro clients. 
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3. Configure Data settings. 

a. For each zone listed in the Zone Information window, use the Zone Edit button to open the Zone Edit 
window. 

 

b. Specify the channel to use for data by assigning the Data Zone-CH/GID (Analog) and Data Zone-
CH/GID (Digital) fields as required for your system. Ensure that the specified channels are the same as 

specified for the Control Station radio in Step 1a.6.b. 
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i. If using FleetSync on a conventional (non-trunked) system, ensure that the correct data will be 

sent to the Data Channel: 

- Open the FleetSync window by using the menu commands: Edit > FleetSync 

- Open the Parameter tab. 

- Enable the desired messages to send across the Data Zone-CH/GID with a Check. 

 

ii. If using NXDN on a conventional system,  

- Open the NXDN window by using the menu commands: Edit > NXDN 

- Open the Conventional tab 

- Enable the desired messages to send across the Data Zone-CH/GID with a Check. 

- Disabling "Status message on Data Zone-CH/GID" will keep the radio check on the 

voice channel. 
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4. Configure Text Message Settings. 

a. Open the Key Assignment window by using the menu commands: Edit > Key Assignment 

b. In the Menu tab, choose Call in the Category List, select SDM (FleetSync/NXDN) in the Function 
List, and then click the Add button.  

 

5. Configure the GPS settings. 

a. If using GPS, configure the desired behavior for the radio by using the menu commands 

Edit > Optional Features > Optional Features 2 and going to the GPS tab. 

b. If GPS data should be sent on another channel, enable GPS Report on Data Zone-CH/GID with a 

Check, and then select the correct channel to use in the GPS Report CH/GID box. 

c. If using GPS with FleetSync, ensure the GPS Base Fleet and Base ID include the Control Station radio 

using the following steps. 

d. Open the FleetSync window by using the menu commands: Edit > FleetSync 
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e. In the GPS tab, enter a value for Base Fleet and Base ID.  

Note: If the Base ID does not include the Control Station(s), data will not appear in RadioPro. 

 

 

f. If using GPS with NXDN, ensure the GPS Base ID includes the Control Station radio.  

i. Open the NXDN window by using the menu commands: Edit > NXDN 

ii. In the GPS tab, enter a value for Base ID Type (GPS) and Base ID (GPS). 
Note: This is the ID the subscriber will to respond to, which will be the ID of the data revert control 

station radio.  
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6. Configure the Data Port 

a. Open the Option Features 1 settings window using the menu commands:  

Edit > Optional Features > Optional Features 1.  

b. Select the Common Page 3 tab, and then under the Function column for COM port 1, select None.  

 

c. Select the Common Page 4 tab, and then enable Short Message Stack with a Check.  
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3.2 Connect the IP Gateway to the Radio 

 

Note: Before continuing, ensure that the programming cable has been disconnected from the front mic 

connector. 

See Section 4.1 Appendix – Radio Interface Cables 

Kenwood NEXEDGE NX700/800 on Page 24 for interface cable details. 

Connect the IP Gateway to the Control Station voice radio using the following steps: 

1. Connect the DB-25 side of cable S2-617691 to the DB-25 connector on the rear of the NEXEDGE NX-800 radio. 

2. Connect the DE-9 male side of the cable to the DE-9 female connector on the rear of the IP Gateway. 

3. Ensure that jack screws on both connectors are tightened to hold connectors in place. 

 

Connect the IP Gateway to the Data Revert Control Station radio using the following steps:  

1. Connect the DB-25 side of cable 89-10505 (DB25 Male to DE9 Female) to the DB-25 connector on the rear of the 

NEXEDGE NX-800 radio. 

2. Connect the DE-9 female side of the cable to the DE-9 male connector on the rear of the IP Gateway. 

3. Ensure that jack screws on both connectors are tightened to hold connectors in place. 

 

Note: Since the IP Gateway has not yet been configured with appropriate IP parameters, do NOT connect the IP 

Gateway to an IP network. 
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3.3 Configure the RadioPro IP Gateway 

 

Note:  Before continuing, ensure that Wi-Fi connection has been disabled in the PC or Laptop being used to 

configure the IP Gateway. 

The RadioPro ICU (IP Configuration Utility) must be used to configure each RadioPro IP Gateway with the necessary 

parameters.  Configuration of each RadioPro IP Gateway must be performed before connecting the IP Gateway to a 

local area network. 

 

Configure RadioPro IP Gateway settings: 

Please Refer to the RadioPro IP Gateway Installation Guide for information about how to connect to the IP 

Gateway and for settings that apply to all radio systems. 

 

Configure NEXEDGE specific settings:  (Once connected to the IP Gateway with the ICU Utility) 

NEXEDGE Radio tab 

Enter the appropriate radio ID values for the fields 

on this tab. 

The Receive PTT ID timeout (ms) field is used 

to give the transmitting radio time to transmit its 

PTT ID before the default PTT ID is used. 

 

 

 

GPS tab 

If mapping locations of subscribers is required, 

place a check mark next to Start GPS polling 
when online status received.  Leave this 

unchecked if GPS mapping is not needed, or if 

subscriber radios have been programmed to start 

GPS polling on their own. 

Then choose a Report interval time to set the 

minimum time between successive GPS updates.   

Increasing this parameter will decrease the number 

of GPS updates, thereby allowing more channel 

bandwidth for voice conversations.   

 

Refer to the RadioPro IP Gateway Installation Guide for instructions on how to connect the RadioPro IP 

Gateway to an IP Network, configure Port Forwarding, and installing RadioPro Clients. 

  

https://ctiproducts.com/documents/radiopro/RadioPro%20IP%20Gateway%20Installation%20Guide.pdf
https://ctiproducts.com/documents/radiopro/RadioPro%20IP%20Gateway%20Installation%20Guide.pdf
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4. APPENDIX 

4.1 Appendix – Radio Interface Cables 

Kenwood NEXEDGE NX700/800 

Voice Radio 

Interface Cable # S2-61769 

Signal Name 
IP Gateway 
DE-9* Pin # 

 

NXx00 Radio 
DB-25 Pin # 

 Tx+ (Mic audio to radio) 
Transformer isolated, 600 ohms 

4 6 

Tx- (Mic audio to radio)  5 25 

Rx+ (Speaker audio from radio) 
Transformer isolated, 600 ohms 

8 17 

Rx- (speaker audio from radio 9 18 

Tx Data (from radio) 1 3 

Rx Data (to radio) 6 2 

Digital Ground 3 7 

* Interface cable requires DE-9 Male to connect to the IP Gateway female connector. 

 

Data Radio 

Interface Cable # 89-10505 (standard DE-9 to DB-25 serial cable) 

Signal Name 
IP Gateway 
DE-9* Pin # 

 

NXx00 Radio 
DB-25 Pin # 

 Tx Data (from radio) 2 3 

Rx Data (to radio) 3 2 

Digital Ground 5 7 

* Interface cable requires DE-9 Male to connect to the IP Gateway female connector. 
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Kenwood NEXEDGE NX720/820 

Voice Radio 

Interface Cable # S2-61890 

Signal Name 
IP Gateway 
DE-9* Pin # 

 

NXx20 Radio 
HD-15 Pin # 

 MI2 (Tx+ Mic audio to radio)  4 5 

Audio Ground  5 15 

AF0 (Rx+ Speaker audio from radio) 8 4 

Audio Ground 9 15 

Tx Data (from radio) 1 6 

Rx Data (to radio) 6 7 

Digital Ground 3 15 

* Interface cable requires DE-9 Male to connect to the IP Gateway female connector. 

Data Radio 

Interface Cable # S2-61891 

Signal Name 
IP Gateway 
DE-9* Pin # 

 

NXx20 Radio 
HD-15 Pin # 

 Tx Data (from radio) 2 6 

Rx Data (to radio) 3 7 

Digital Ground 5 15 

Additional modifications to internal Tx-Rx unit of NX-720/820 

Out In Description 

R664 R666 Change FNC1 (TXD) and FNC2 (RXD)  
of HD-15 (DE-15) Connector 

from TTL level to RS-232C level 

R635 R633 

R662 R665 

R796 R798 Change signal output from DEO to AFO 

R797 R799 Change signal input from DI to MI2 
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6. SYSTEM PLANNER TEMPLATE PAGE 1 OF 2 

RadioPro IP Gateways 

Parameters Common to all IP Gateways 

ICU.exe Admin Password 
for ICU.exe, default is “admin” 

Dispatch Client Password 
for Dispatch client connections 

default is “user” 

NTP Server IP Address 
Network Time Protocol 

   

 

Parameters Unique to each IP Gateway 
GPS = GPS Data Revert. 

Each IP Gateway supports 1 
Voice & 1 GPS Data Radio. 

Name 
IP Gateway name has max 2 

lines, 24 chars per line 

Serial 
# 

IP Address Subnet Mask 
Default 

Gateway 

IP Gateway A Example Gateway Name 1234 192.168.56.22 255.255.255.0 192.168.56.1 

Voice Radio A0 Example Radio VR A0  192.168.10.1 255.255.255.0  

GPS Radio A1 Example Radio GPS A1  192.168.11.1 255.255.255.0  

IP Gateway B      

Voice Radio B0      

GPS Radio B1      

IP Gateway C      

Voice Radio C0      

GPS Radio C1      

IP Gateway D      

Voice Radio D0      

GPS Radio D1      

IP Gateway E      

Voice Radio D0      

GPS Radio D1      

IP Gateway F      

Voice Radio D0      

GPS Radio D1      

IP Gateway G      

Voice Radio D0      

GPS Radio D1      

IP Gateway H      

Voice Radio D0      

GPS Radio D1      

IP Gateway J      

Voice Radio E0      

GPS Radio E1      

If additional IP Gateways are needed, copy this page. 

See next page for System Planner Template Page 2 of 2 
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SYSTEM PLANNER TEMPLATE PAGE 2 OF 2 

RadioPro Dispatch Clients 

See RadioPro Dispatch Installation and Configuration Guide S2-61785 for more information. 

Parameters Common Parameters Unique 
to all Dispatch clients to each Dispatch client 

Administrator Password 
for Edit Mode 

 PC Name 
 

IP Address 
 

License 
# 

Licensed IP Gateway 
Connections 

      

      

      

      

      

      

      

      

RadioPro Solo, Talk, and Mobile Clients 

See RadioPro Solo Client Installation Guide S2-61568, for more information. 

Parameters Common to all Talk Clients 

Administrator Login Name 
Not Editable 

Administrator Password 
default is “admin” 

admin  

 

User Login Name 
default is “user” 

User Password 
default is “user” 

  

  

  

  

  

  

  

  

  

  

If additional Solo, Talk, or Mobile client logins are needed, copy this page. 

https://ctiproducts.com/documents/radiopro/RadioPro%20Dispatch%20Installation%20and%20Configuration%20Guide%20S2-61785.pdf
https://ctiproducts.com/documents/radiopro/RadioPro%20Solo%20Client%20Installation%20Guide%20S2-61568.pdf
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	Additional modifications to internal Tx-Rx unit of NX-720/820
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