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1 SYSTEM OVERVIEW 

RadioPro™ provides remote access to 2-way radios via IP Networks.  This “Dispatch over IP” (DoIP) solution consists 

of PC-based software allowing voice and data communications between PC users and 2-way radio subscribers.  

Communications with radio subscribers is also possible for remote mobile users using Android or iOS devices. A 

RadioPro system consists of at least one RadioPro IP Gateway (server) and at least one client (Dispatch™, Solo™, or 

Talk for Mobile™) with an IP network connecting the RadioPro components.    

1.1 System Components 

CTI’s Dispatch over IP system is based on Server-Client architecture.  System components are described below: 

• RadioPro IP Gateway Kit  (CTI Part # S2-61815) is the hardware 

interface that connects a mobile radio (control station) to an IP 

network.  The IP Gateway is the Server for the control station radio 

connected to it.  Each control station radio used for voice requires 

one IP Gateway.    System components, such as IP Gateways and 

clients (Dispatch, Solo, or Talk Mobile), may be located together or 

separated geographically and connected via a Wide Area Network (WAN) or Virtual Private Network 

(VPN).  An optional license can be purchased for the IP Gateway to allow users of Solo or Talk for 

Mobile client applications to connect to the two-way radio system.  Each IP Gateway requires a static IP 

address.  For more information, see the following documents: 

RadioPro IP Gateway Installation Guide 

RadioPro IP Gateway Data Sheet 

RadioPro Family of Products 

 

• RadioPro Dispatch Client  

is a dispatch console for PCs that provides voice 

dispatching to multiple simultaneous radio channels or 

talk groups, as well as GPS/AVL, Telemetry, Text 

Messaging, and Voice Logging.  Windows 10 Pro, 8 

Pro or Windows 7 Pro operating system is required.  

This application can be used with either Motorola 

MOTOTRBO or Kenwood NEXEDGE systems. 

System components, such as Dispatch clients and IP 

Gateways, may be located together or separated 

geographically and connected via a Wide Area 

Network (WAN) or Virtual Private Network (VPN). 

 

CTI Part #s  Licensable Feature 

S1-61770  Core 

S1-61771  Voice Module 

S1-61772  GPS Module 

S1-61773  Telemetry Module 

S1-61774  Text Messaging Module  

 

Additional information: 

RadioPro Dispatch User Guide 

RadioPro Dispatch Data Sheet 

RadioPro System Accessories Catalog 

 

  

https://ctiproducts.com/documents/radiopro/v9/RadioPro%20IP%20Gateway%20Installation%20Guide.pdf
https://ctiproducts.com/documents/radiopro/v9/RadioPro%20IP%20Gateway%20Installation%20Guide.pdf
https://ctiproducts.com/documents/radiopro/v9/RadioPro%20IP%20Gateway%20Data%20Sheet.pdf
https://ctiproducts.com/documents/radiopro/v9/RadioPro%20Family%20of%20Products.pdf
https://ctiproducts.com/documents/radiopro/v9/RadioPro%20Dispatch%20User%20Guide.pdf
https://ctiproducts.com/documents/radiopro/v9/RadioPro%20Dispatch%20Data%20Sheet.pdf
https://ctiproducts.com/documents/radiopro/v9/RadioPro%20System%20Accessories.pdf
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• Solo™ Client is a software application for Windows that provides voice dispatching to a single radio 

channel or talk group.  The virtual radio head duplicates the full functionality of a control station radio 

including channel steering for these radio models: 

 

Motorola  

XPR 2500, XPR 5550, XPR 5550e 

 

  Kenwood  

NX-700/720/3720, NX-800/820/3820,  

NX-5700, NX-5800    

 

Other features include Voice Logging for 24 hours, Text Messaging, and channel steering.  It requires 

Windows 7, 8 or 10 operating system.  The use of this application requires a license installed on the IP 

Gateway.  The license will permit 80 simultaneous Solo or Talk Mobile application users to connect to the 

radio system.  System components, such as clients and IP Gateways, may be located together or separated 

geographically and connected via a Wide Area Network (WAN) or Virtual Private Network (VPN).   

 

Additional Information: 

RadioPro Solo Client Installation Guide 

RadioPro Solo User Guide 

RadioPro Solo Data Sheet 

 

 

 

• Talk™ for Mobile devices is a mobile app for Android™ and iPhone™/iPad™ that 

provides remote access to a 2-way radio system for voice communications, text messaging, 

and locating other users.  This application can be used with either Motorola MOTOTRBO 

or Kenwood NEXEDGE systems.  The Mobile app is useful over cellular or Wi-Fi 

networks when you are on-the-go and outside the coverage of your radio system, yet still 

need radio communications. The use of this application requires a license installed on the 

IP Gateway.  The license will permit 80 simultaneous Solo or Talk Mobile application 

users to connect to the radio system.   

 

Additional Information: 

RadioPro Talk for Mobile Devices How-to-Guide 

RadioPro Talk for Mobile Devices Data Sheet 

 

 

  

https://ctiproducts.com/documents/radiopro/v9/RadioPro%20Solo%20Client%20Installation%20Guide.pdf
https://ctiproducts.com/documents/radiopro/v9/RadioPro%20Solo%20Client%20Installation%20Guide.pdf
https://ctiproducts.com/documents/radiopro/v9/RadioPro%20Solo%20User%20Guide.pdf
https://ctiproducts.com/documents/radiopro/v9/RadioPro%20Solo%20Data%20Sheet.pdf
https://ctiproducts.com/documents/radiopro/v9/RadioPro%20Talk%20for%20mobile%20devices%20How-to%20Guide.pdf
https://ctiproducts.com/documents/radiopro/v9/RadioPro%20Talk%20for%20Mobile%20devices%20Data%20Sheet.pdf
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• Control Station Radio - A control station radio must be used as the interface to the radio system, and 

connects to a RadioPro IP Gateway using the rear accessory/communications port.  Each control station 

radio used for voice requires one IP Gateway.  Radio models that can be used for a Control Station radio 

and provide full radio functionality from a RadioPro client include:  

• Motorola MOTOTRBO: XPR 2500/5550/5550e 

  

• Kenwood NEXEDGE:  NX-700/800 NX-720/820  

  NX-3720/3820 NX-5700/5800 

 

• Personal Computer or Workstation is required to host the RadioPro Dispatch or Solo clients.  See PCs 

for Dispatch Client on Page 10 for more details. 

 

• Accessories - Console accessories may include microphone and speakers (or headset), Push-to-Talk 

footswitch, and touch screen monitor.  See RadioPro Accessories Catalog for details. 

 

  

https://ctiproducts.com/documents/radiopro/v9/RadioPro%20System%20Accessories.pdf
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1.2 Architecture 

The IP Gateways interface the radio system to an IP network.  One IP Gateway is required for each control station radio 

used for voice.  The IP Gateways and control station radios can be centrally located or scattered among different locations 

using a Virtual Private Network (VPN) or Wide Area Network (WAN) such as the Internet.  

Each IP Gateway in a RadioPro system acts as the server for the Control Station Radio connected to it, and ensures easy 

wide-area deployment.  Since there is not a server PC, the architecture reduces “single point-of-failure” concerns.   

A system may have a mixture of RadioPro Dispatch, Solo, and RadioPro Talk for Mobile apps running on mobile devices. 

These Clients may be centrally located or scattered among different locations using a Virtual Private Network (VPN) or 

Wide Area Network (WAN) such as the Internet.  
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System Component Limits 

The RadioPro solution was tested and verified to operate up to the maximum number of components listed below. 

  

 

System Planner Document and Template 

The RadioPro System Planner includes examples for various radio network topologies, and should be consulted if the 

RadioPro Dispatch client is being deployed. 

Use the System Planner Template (located at the end of this document) in the planning phase of a project to record IP 

addresses, usernames, passwords, serial numbers, and device names. 

Maximum of 80 Clients per IP Gateway 

Maximum of 70 IP Gateways per Dispatch Client 

https://ctiproducts.com/documents/radiopro/v9/RadioPro%20System%20Planner%20for%20Motorola%20MOTOTRBO.pdf
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1.3 What You Will Need 

PCs for Dispatch Client 

PCs that will be used to run the RadioPro Dispatch client software must have the following:  

• Processor:  Intel Core i5, or better 

• Operating System: Windows 10 Pro recommended.  Dispatch client must have “Run as Administrator” 

enabled under the “Privilege Level” topic of the “Compatibility” tab. 

• Memory:  8 GBytes recommended (4 GBytes minimum)  

• 1st Hard Disk:  160 GBytes minimum, for Operating System. 

• 2nd Partition or Hard Disk:  2 TBytes recommended, for Voice & Event History Logging (500 GBytes 

minimum).  The 2nd Hard Disk may be an external hard disk connected via eSATA, or a network storage 

device.  (Externally connected USB drives are not recommended since many have access times that are too 

slow.) Alternatively, a 2nd partition on the first hard disk could be used for History Logging.  (Logging is 

not permitted on the C Partition.)  At normal Sampling Rate of 11kBytes/s, continuous recording (100% 

duty) of one radio channel for 24 hours will require 1.9 GBytes of Hard Disk space.  Normal channel activity 

will range from 10% to 60% duty. 

• IP Network Interface:  10Mbps or faster.  Network bandwidth requirement is 22kBytes/s (maximum) for 

each connected RadioPro IP Gateway.  

• Monitors: Dual recommended if both voice dispatching and GPS mapping functions are used, 20” minimum 

each, 23” recommended. 

• Headset (USB, Analog, or Bluetooth), or Desktop Mic and Stereo Speakers 

PCs will also require .Net version 4.0 or higher.  During installation of the RadioPro Dispatch client software, allow this 

update to occur.  During Windows updates, select all optional updates. 

Audio and PTT Accessories 

A professional quality desk microphone and speakers will be needed to transmit and receive audio between a Dispatcher 

and the radio system.  Alternatively, a professional quality headset can be used. 

One or more footswitches may also be installed to activate Push-to-Talk for one or more radio channels. 

See RadioPro System Accessories brochure for recommended accessories. 

RadioPro Dispatch Client Distribution USB Flash Drive 

The RadioPro Dispatch client is available on the distribution USB Flash Drive. 

RadioPro Dispatch License USB Flash Drive 

Each PC that runs the RadioPro Dispatch client requires a unique software license file.  Installation of a valid software 

license allows the following: 

• Connection to a number of RadioPro IP Gateways. 

• Proper operation of software modules such as Voice, GPS, Text, and Telemetry. 

USB Flash Drive contains this license file.   Connections for additional IP Gateways and additional modules can be 

purchased and added to the license file at any time. 

RadioPro Dispatch can be run in “Demo Mode” without the use of a software license.  In Demo Mode, a RadioPro 

Dispatch client can connect only to CTI’s demo radio system in Cincinnati, Ohio. 

 

 

 

https://ctiproducts.com/documents/radiopro/v9/RadioPro%20System%20Accessories.pdf
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1.4 System Considerations 

System Planner Template 

Use the System Planner Template at the end of this document to record device names, passwords, and IP addresses. 

IP Gateway and Control Station Radio Configuration 

Before installing the RadioPro Dispatch client, the IP Gateway (s) must be configured using the ICU.exe utility (IP 

Configuration Utility) and installed on an IP network. In addition, the Control Station(s) must be configured using the 

manufacturer’s configuration software.  See the RadioPro IP Gateway Installation Guide for more details. 

GPS Mapping Support 

Note:  GPS Mapping is not available in all configurations.  Please see Section 5.5 Feature Availability on Page 63 for 

more details. 

Mapping of subscriber radios requires the following: 

• IP Gateways must have GPS enabled using ICU.exe 

• Control Station radios CANNOT have GPS or ARS enabled 

• Subscriber radios MUST have GPS and ARS enabled 

Version Match 

RadioPro Dispatch clients and IP Gateways must have compatible versions in order to communicate with each other.  

Compatibility can be ensured when the first two digits of the version match. (The third digit indicates a minor revision, 

and does not need to match.) 

In addition, the license file for a RadioPro Dispatch client must be at the same major revision level.  In other words, a 

RadioPro Dispatch software license key for version 9 is required to run RadioPro Dispatch version 9.  (A version 8 license 

key will not be able to run RadioPro Dispatch version 9.) 

Control Station Radio Version 

The control station radio connected to the IP Gateway must at least have the minimum firmware version listed below. 

Control Station Radio Minimum Version 

Motorola MOTOTRBO in Conventional, IPSC, Cap+, or LCP 1.08.0 

Motorola MOTOTRBO in Connect Plus mode 2.2.0 

Motorola MOTOTRBO Connect Plus Option Board 1.3.0 

Kenwood NEXEDGE NX-800  1.23.00 

 

PC Settings for Power and Display 

Power Settings  
The Power Settings should be adjusted so that the PC does NOT hibernate or sleep.  Use the Power Options item in the 

Control Panel to make these adjustments. 

USB Controller Settings 
USB controllers within the Dispatch PC should be configured to disallow power management.  Use the Device 

Manager item in the Control Panel to make these adjustments.  In the Device Manager window, open the Universal 

Serial Bus controllers folder.  And then for each USB Root Hub listed, use the Power Management tab to disable 

“Allow the computer to turn off this device to save power”. 

 

https://ctiproducts.com/documents/radiopro/v9/RadioPro%20IP%20Gateway%20Installation%20Guide.pdf
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Display Properties 
The RadioPro Dispatch client has been designed to be used with display monitors with the following display properties: 

• Font Size – Normal 

• DPI - Normal (96DPI) 

Altering the above settings may cause some information for the RadioPro Dispatch client to be displayed improperly. 

Touch Screen 

RadioPro Dispatch software will interpret touches on a touch screen as general game controller events.  If a touch screen 

is being deployed for this software installation, then disable touch parameters in the Windows operating system, usually 

found in the Control Panel under “Tablet PC Settings”. 
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2. INSTALL TIME SERVER 

During installation of the IP Gateways, the IP address of a “NTP Server” may have been specified using the ICU (IP 

Configuration Utility).  In order for all IP Gateways to report the same time, and logging at the Dispatch client to have 

accurate times, the IP Gateways must all reference the same Time Server.  This Time Server can be one of the following: 

• An existing Time Server on the Local Area Network. 

• Public domain Time Server accessed using the Internet. 

• Local Time Server installed on a common PC, such as the Dispatch client console PC. 
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3. RADIOPRO DISPATCH CLIENT INSTALLATION 

Prior to installing the RadioPro Dispatch client software, any required IP Gateways should be installed.  See the 

RadioPro IP Gateway Installation Guide for additional details. 

Step 1. Install Audio and PTT Accessories 

Install any required microphones, speakers, headsets, and push-to-talk devices.  Allow the Windows operating system to 

discover these devices and automatically install device drivers before continuing. 

See the RadioPro System Accessories brochure for recommended accessories. 

 

Step 2. Install RadioPro Dispatch Client Software 
Insert the installation USB flash drive into an available USB port. Navigate to and double-click the file named 

“\RadioPro Dispatch Software\RadioPro Dispatch.exe”. 

The RadioPro Dispatch client must have the Run as Administrator parameter enabled as follows. 

Windows 10 Professional 

a. Right-click on the RadioPro Dispatch icon on the desktop, then click Properties from the menu. 

b. On the Shortcut tab, click the Advanced button, and then place a check in the box for Run as administrator. 

 

Step 3. Start the RadioPro Dispatch Client Software 

Double-click the RadioPro Dispatch icon on the PC 

desktop to start the program.  The initial (unconfigured) 

screen may appear similar to this screen capture: 

Use the following steps to import a Software License: 

1. Insert the RadioPro Dispatch License USB flash 

drive into an available USB port. 

2. Click the Import New License button. 

3. Choose the License File on the USB flash drive, 

and then click the OK button. 

 

 

If you receive this error: 

  

restart dispatch as an administrator and follow steps 1 – 3. 

https://ctiproducts.com/documents/radiopro/v9/RadioPro%20IP%20Gateway%20Installation%20Guide.pdf
https://ctiproducts.com/documents/radiopro/v9/RadioPro%20System%20Accessories.pdf
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4. CONFIGURATION 

4.1 Configuration Overview 

Configuring RadioPro Dispatch involves the following steps: 

1. Create an Administrator Password (Page 17) 

Create a password that administrators will use to configure RadioPro Dispatch. 

2. Manage IP Gateways (Page 18)  

Use the Manage IP Gateways window to configure connections to the IP Gateways. 

3. Configure Audio Device Presets (Page 20) 

Configure microphones, headsets and speakers for transmit and receive audio. 

4. Choose and arrange Panels to be shown (Page 27) 

Choose which panels to show such as Subscribers, Recent History, Messages, Geo-fence Alerts, Telemetry, and 

Missed Calls 

5. Add Tabs for Voice and GPS Maps (Page 29) 

Show and arrange the locations of the dock-able tabs for Voice channels and GPS Maps. 

6. Add and configure Radio Controllers for Voice functions (Page 29)  

Add radio controllers to voice tabs for each Talk Group or channel to be accessed. 

7. Add and configure Subscribers and Subscriber Groups (Page 31) 

Add subscribers to groups in the subscriber tab. 

8. Configure other Dispatch options (Page 33) 

Select options that will customize the way in which Voice and GPS tabs function. 

Configuration can be performed only if the program is in Edit mode.  To change to Edit mode, click on the File menu, 

and then click Edit.  (If Lock is displayed in the menu, then the RadioPro Dispatch client is already in Edit mode.) 

4.2 Example Configuration 

RadioPro Dispatch may be configured in many different ways.  An example configuration is shown below. 

 

 

  

Subscribers List 
 
 
 
 
 

Radio Controller 
Tabs for Voice 

 
 
 

Recent History & 
Geo-fence Alerts 

Tabs 
 

Toolbar 
 
 
 
 
 
 
 
Map Tabs 
 
 
 
 
 
 
 
Text Messaging & 
Missed Calls 
Tabs 
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4.3 Configuration using Cloned Settings 

If a Dispatch console PC has already been configured, and it is desired to clone that configuration to additional console 

PCs, then use the Clone function using the following steps. 

 

On the already-configured console PC: 

1. Change RadioPro Dispatch to Edit mode by clicking on the File menu, and then choose Edit. 

2. From the File menu, choose Clone Settings, and then then choose a file name and storage location. A file will be 

saved with an extension of  “.trbodat”. 

3. From the File menu, choose Lock to return RadioPro Dispatch to the Run mode. 

4. Copy the file saved above to a USB flash drive or network storage location. 

 

On the unconfigured console PC:  

5. Change RadioPro Dispatch to Edit mode by clicking on the File menu, and then choose Edit. 

6. From the File menu, choose Import Cloned Settings, and then then choose a file name and storage location 

selected in Step 4 above.  

7. Import the License File for this Dispatch console. 

a. While in Edit mode, click the Options menu item, then click 

Update License to display the Update License window 

shown at right. 

b. Insert the License Key USB into an available USB port.   

c. Click the Import button, and then locate and select the License 

Key file on mounted USB drive.  The Update License 
window should now reflect the licensing allowed for this 

installation, similar to the screen-capture at right. 

d. Close the Update License window. 

8. From the File menu, choose Lock to return RadioPro Dispatch to the 

Run mode. 
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4.4 Configuration without using Cloned Settings 

Step 1. Create an Administrator Password 
A person using the RadioPro Dispatch client can be either a User or an Administrator.  An Administrator will be allowed 

to make changes to RadioPro Dispatch using a password. A User will be prevented from making changes to the 

configuration. 

An Administrator password can be created by using the following steps: 

1. If not already in Edit mode, change to Edit mode by clicking on the File menu, and then choose Edit. 

2. From the File menu, click Save As, and then choose a file storage location such as: 
  c:\Program Files (x86)\CTI Products\RadioPro 

After choosing a filename and storage location for this configuration file, the following Password Protect File 

window will be displayed. 

3. Enter a password into both the New Password and Confirm Password boxes, and then click the Set Password 

button. 
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Step 2. Manage IP Gateways 

While in Edit mode, configure the connections to IP Gateways using the following steps: 

1. Click on the Options menu, then click Manage IP Gateways to  display the following window: 

2. Click the  button to display the following Add Gateway window:  

3. In the Gateway Address field, enter the IP Address for the RadioPro IP Gateway.   

4. If there is a failover gateway, check the box next to the Secondary Address and enter the IP Address for the 

backup gateway.  

With a Secondary Address the right-click “Pri / Sec” menu for this gateway will have the following 

selections: 

 

o Auto – This is the default failover behavior where the primary gateway is used unless it is down, then the 

secondary will be used until the primary is available again. 

o Primary – This selection forces only the primary gateway to be used. 

o Secondary – This selection forces only the secondary gateway to be used. 

5. Modify the port of the gateway by changing the value in the Port field.   

o The default port used by a RadioPro IP Gateway is TCP port 48222.  If needed, the port number of an IP 

Gateway can be changed by using the ICU.exe utility.   

o If the IP Gateway is connected to a different IP LAN subnet than the RadioPro Dispatch client PC, then 

enter the external IP address of the firewall or router that is protecting that subnet. In this case, a port-

forwarding rule is needed to be programmed into the firewall or router for each IP Gateway. 

See the RadioPro IP Gateway Installation Guide for additional details.  

6. Enter the Password for the IP Gateway.   

7. Click the Test button to determine if the RadioPro IP Gateway is accessible using the IP Network.  “Connection 

Successful” will be displayed if the connection succeeded. 

8. Finally, click the Add button to add this RadioPro IP Gateway to the device list as shown in the following: 

 

 Table headings in the above window are defined as follows: 

https://ctiproducts.com/documents/radiopro/v9/RadioPro%20IP%20Gateway%20Installation%20Guide.pdf


RadioPro Dispatch Installation and Configuration Guide 

 19  

 

Address 

IP Address assigned to IP Gateway, and Port Number 

Name 

Name assigned to IP Gateway 

Gateway Status 

Indicates Connected and firmware version of IP Gateway, or Not Connected 

Pri / Sec 

Indicates if the gateway is set for Auto, Primary, or Secondary. 

Radio Version 

Indicates firmware version of Radio if connected, or Not Connected 

Date / Time 

Date and Time being used by IP Gateway 

Record Option 

Checking this option allows logging of audio for this IP Gateway to the database 

Audio Option 

Checking this option allows audio to be heard for this IP Gateway 

Text Option 

Checking this option allows text messaging for this IP Gateway 

9. Repeat Steps 2 through 8 for each RadioPro IP Gateway in the system. 

10. To remove a RadioPro IP Gateway from the device list, select the device, and then click the  button. 

11. To edit the IP Address or Password for an IP Gateway, first select the IP Gateway from the list, and then click the 

  button. 
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Step 3. Configure Audio Device Presets 

While in Edit mode, options are available that will customize the way in which audio will be transmitted and received.  

Click on the Options menu, click Audio Presets, and then click Configure to display the following window. 

  

 

 Click the  button to save all Audio Configuration settings. 

 

General tab 

Use this tab to configure audio parameters such as Muting and Audio Quality. 

Mute Audio When Transmitting 

Mutes all receiving audio while the dispatch is transmitting. This option will prevent audio feedback 

while the dispatcher is transmitting. 

Enable PC Cross Mute 

Select this option to mute audio from adjacent PCs.  Adjacent PCs should have the SAME Cross Mute 

ID selected. Dispatch positions with the same cross mute ID will not be able to hear eachother. This is 

also referred to as “Audio Cross Muting” . 

Audio Quality 

Compressed Mode  (2.2kBytes/s per client user and Talk Group) should be used when either: 

 a RadioPro client is connected to the IP Gateway(s) using a WAN such as the Internet, or 

 there is a concern that “High Quality” mode will use too much bandwidth. 

High Quality Mode  (22kBytes/s per client and Talk Group) should be used when: 

 Neither of the conditions listed above for “Compressed Mode” exist, and 

   the additional 10% improvement in audio quality is needed. 

 

  

Click the  button to save all Audio Configuration settings. 

 

Note:  The configuration file for 

Audio Settings can be located and 

viewed by clicking on the file name 

“AudioSettings.cfg” 
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Devices tab 

Use this tab to add Audio Presets to the Options menu. Multiple Audio Presets can be entered to accommodate 

several different audio configurations using different microphones, headsets, and desk speakers.   

 

Presets 

This section lists the current audio device configurations. Use the  and  buttons to add or delete 

an audio preset from the Options menu. 

Preset Name 

Edit this name as it should appear in the Options menu. 

Mic In 

From the drop-down list, select a microphone. 

Select Out 

From the drop-down list, select a device for Select Audio playback, as well as Both, Left, or Right 

speaker. 

Unselect Out 

From the drop-down list, select a device for Unselect Audio playback, as well as Both, Left, or Right 

speaker.  

Intercom Out 

From the drop-down list, select a device for audio from other RadioPro Dispatch clients, as well as Both, 

Left, or Right speaker.  

Click the  button to save all Audio Configuration settings. 
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Levels tab 

Use this tab to set the initial audio volume levels at program start-up. Mic, Select, and Unselect volumes can be changed 

by the dispatcher while the application is running. 

  

 

Mic Volume 
Select the initial microphone volume level.  The initial setting for this parameter should be 100%.  The 

number in the min column allows you to set the minimum volume percent.  If audio heard on portable 

and mobile radios is not loud enough, adjust the Rear Mic Gain settings in the Control Station radios 

connected to RadioPro IP Gateways.  See the RadioPro IP Gateway Installation Guide for specific 

radio model programming guides. 

Select Volume 

Select the initial receive volume level for Selected talk groups. The initial setting for this parameter 

should be 100%.  The number in the min column allows you to set the minimum volume percent. 

Unselect Volume 

Select the initial receive volume level for Unselected talk groups.  The initial setting for this parameter 

should be 60%.  The number in the min column allows you to set the minimum volume percent. 

Intercom Volume 

Select the receive volume level from other RadioPro Dispatch clients.  The initial setting for this 

parameter should be 60%.   

Alert Sounds 

Select the volume level for Alert Sounds, such as “Talk-Permit”  and “Channel-Busy”.  The initial 

setting for this parameter should be 30%.   

Click the  button to save all Audio Configuration settings. 

https://ctiproducts.com/documents/radiopro/v9/RadioPro%20IP%20Gateway%20Installation%20Guide.pdf
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Advanced tab 

Use the advanced tab to set rules for duplicate PTT ID audio and to control Intercom audio levels.  
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Mute audio streams from radios connected to a gateway 

Select this option if audio transmissions are being received by another radio connected to the RadioPro 

Dispatch client.  This feature works by comparing the incoming audio PTT-ID with ID’s of the radios 

connected to the gateways. This feature does not work with analog calls where the PTT-ID is not 

available.  This is also referred to as “RF Cross Muting”.  

   

RadioPro Dispatch 

Gateway #1 

Radio #1 

PC Speaker 

Radio Transmission with Radio #1 PTT ID. 
 
Transmission is picked up by Radio #2. 

Gateway #2 

Talk Group #1 Talk Group #2 

Radio #2 

       Mute audio 
    streams from  
radios connected     
    to a Gateway? 

Start Audio 
Transmission in 
Dispatch 

Audio is Muted 
(Audio is still archived) 

Yes 

No 

Mute audio streams from radios  
    connected to a gateway 

Dispatch will mute audio if it detects that 
the audio is coming from another gateway. 
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Mute duplicate audio streams from the same radio source 

If two audio streams from the same radio source occur at the same time, this option will playback the 

first audio stream and mute the second audio stream. This feature works by comparing the PTT-ID’s of 

the incoming radio traffic. If two receiving streams have the same PTT-ID, then one will be muted to 

prevent echoing. 

          

Intercom Audio uses select/unselect device and speaker 

Select this option to direct received intercom audio to same audio devices configured for Select and 

Unselect volume.  If this option is not enabled, then received Intercom Audio will be directed to device 

chosen for the Intercom Out parameter located in the Devices tab.  

RadioPro Dispatch 

Gateway #1 

Radio #1 

PC Speaker 

A radio transmission with the same PTT ID is received by radio #1 and radio #2.  
The audio from radio #1 is received by Dispatch first. 
The audio from radio #2 is received while radio #1’s audio is still playing. 

Gateway #2 

Talk Group #1 Talk Group #2 

Radio #2 

               Mute  
       duplicate audio 
    streams from the  
          same radio 
              source? 

Audio is Muted 
(Audio is still archived) 

 

Yes 

No 

Source Radio 

The talk group that receives 
audio first will not be muted. 

Mute duplicate audio streams  
    from the same radio source 

The talk group that receives audio second will 
be muted when this setting is turned on. 
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Intercom Audio uses select/unselect volume 

Select this option to modify the volume level set for the Intercom Volume parameter located in the 

Devices tab based on whether the receiving radio is Selected or Unselected. 

Intercom Audio uses radio talk group volume 

Select this option to modify the volume level set for the Intercom Volume parameter located in the 

Devices tab based on the volume level set in the Radio Controller for a particular talk group.  

  

 

GW 
Selected 

GW 
Unselecte

RadioPro IP Gateway 

     Intercom 
   Audio uses 
Select/Unselect 
     volume? 

Yes 

No 

        RadioPro 
Dispatch 

     Intercom 
   Audio uses  
radio talkgroup 
      volume? 

Yes 

No 

Intercom Volume 

PC Speaker 

       IP Client 

Intercom Audio Path 
- Intercom Audio uses select/unselect volume 
- Intercom Audio uses radio talk group volume 
- Intercom Volume 
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Step 4. Choose and Arrange Panels 

The Main Window can be customized to show various dock-able tabbed Panels. While in Edit mode, use the Show menu 

to choose among the following Panels to be displayed on the Main Window. 

• Subscribers – A list of subscriber radio IDs and Alias Names, along with 

function buttons for Private Call, GPS Locate, Radio Check, Call Alert, 

Remote Monitor, Enable (radio), and Disable (radio) 

• Recent History – A list of the most recent radio events, including sent and 

received audio, sent and received text messages, call alerts, and 

emergencies. 

• Messages – A list of outgoing and incoming text messages, along with a text 

box and Send button for initiating messages. 

• Geo-fence Alerts – A list of radio subscriber units that are currently meeting a Geo-fence condition. 

• Telemetry – A list of I/O points in vehicles and facilities that can be monitored and controlled 

• Missed Calls – A list of incoming private calls that have not been responded to from the Dispatcher with a 

return private call. 

When enabled with a check mark from the Show menu, a Panel will appear in its default location until moved to a different 

location.  
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Arranging Panels 

While in Edit mode, each panel may be located to another position by using the following steps: 

1. Click and drag a Panel using its tab area.  While the Panel is being moved, Tab Anchor Points will be displayed as shown 

below. 

  

2. To dock the Panel at a pre-defined position, drop the Panel onto any of the Panel Anchor Points displayed.  Options 

include left-side, right-side, top, bottom, and as a member of a set of panels.  To make the panel a member of a set of 

panels, drop the tab onto the center of the Panel Anchor Point. 

 

3. To un-dock a Panel, so that it floats to a location chosen by the User, drop the Panel onto an area of the screen that does 

not have a Panel Anchor Point.  
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Step 5. Add Tabs for Voice and GPS Maps 
Depending on the license purchased, it is possible to add one or more Voice 

tabs and/or one or more GPS Map tabs to the Main window. To add a tab, use 

the following steps: 

a. Click the  button to display the New Tab Page window. 

 

b. In the New Tab Page window, enter the Page Name, choose the Page Type, and then 

click the Add button. 

Repeat the steps listed above for each tab needed. 

 

Step 6. Add and Configure Radio Controllers for Voice functions  

While in Edit mode, add radio controllers to a tabbed page using the following steps: 

a. Select a tab, then click the   tool located next to the tab to display the Select Radios window shown:  

b. Place a check mark next to all devices that should be displayed on the active Radio Controllers Tab, then click the 

OK button.  The selected Radio Controllers will be displayed on the active Radio Controllers Tab. 

 

Each Radio Controller on a tabbed page may be customized using the remaining steps: 

c. Click the    button on the title bar of a Radio Controller to display the Options window:  

d. Optionally, click the Outline Color    button to select a border 

color for this Radio Controller.  Click the    button to make the 

selected color the default. 

e. Enable an option for Title label to display either the Gateway Name 

or Channel Name in the header portion of the Radio Controller. 

f. Choose if History Items should be displayed for this Radio 

Controller. If a number greater than ‘0’ is chosen, then incoming 

voice messages for this Radio Controller will be shown in the lower 

portion of the window. 

g. The Min Volume can be set to a number between 0 and 100.  A Min Volume set to 

10 will not allow the volume slider to go below 10%. 

  

Step d. 

Step e. 

Step f. 

Step g. 

Step h. 
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h. Click the check boxes in this window to enable other needed features.  

1) Audio Isolate: Enable this option to make an audio isolate button available 

for this Radio Controller.  When the audio isolate button is pressed, all 

Radio Controllers are muted except that Radio Controller and any 

other Radio Controllers with audio isolate buttons enabled. 

2) Enable double-click to Mute: When this option in Enabled, double-

clicking the volume button will mute the volume. 

3) Allow channel to be patched: Enable this option to allow the 

Dispatcher to patch this Talk Group (channel) to another Talk Group.  

When this option is enabled, the Patch button will be added to this 

Radio Controller.  When the Dispatcher patches two talk groups 

together using this button, transmit and receive voice traffic will be 

shared by both.  If this option is enabled for Radio Controllers on 

other Dispatch clients, patch status will be displayed on these other 

clients.  Only a single patch is available, and a maximum of 3 Talk 

Groups may be patched.   

4) Call status: Enable this option to display caller ID and status symbols for 

“transmitting” and “receiving”.  

5) RSSI: Enable this option to continuously show the RSSI level reported by the control station radio (if 

available).  RSSI levels are displayed in decibel-milliwatts (dBm).   

6) Radio Display: Enable this option to duplicate the display from the Control Station radio. 

7) Radio menu buttons:  Enable this option to display menu buttons, allowing the Dispatcher to access the 

menu items of the Control Station radio. 

8) PTT button: Enable this option to display the PTT button. 

9) History items:  Enable this option by selecting a number greater than 0.  When enabled, incoming calls 

will be listed for this channel. 

10) Channel/Zone selector: Enable this option to allow the Dispatcher to change zones and channels from 

this Radio Controller. 

11) P buttons: Enable one or more of these to display the programmable buttons on the Control Station radio. 

i. Click the OK button to save the Radio Controller settings.  

j. The Radio Controller can be resized by dragging its lower right-hand corner to a new position as follows: 

1) Hover the mouse over the lower right-hand corner of a Radio Controller 

window.   

The cursor will change to a double-arrow resizing symbol.   

2) Click the mouse and drag the corner to a new position.  

 

 

Editing Tab Features 

To change the Radio Controllers that appear on a tab, or to rename a tab, click the   

button.  

Step h4. 

Step h8. 

Step h3. 

Step h5. 

Step h6. 

Step h9. 

Step h10. 

Step h11. 

Step h1. 

Step h7. 

Step h2. 
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Step 7. Add and configure Subscribers and Subscriber Groups 

This step may not be necessary if aliases have already been set up in your gateway.  The ICU utility that manages the 

gateway settings has an Aliases tab where radio id’s can be given names more appropriate for your organizations use.  

The Dispatch software will use this set of Aliases. 

 

In the Subscribers tab, an “All” group is automatically added for you with radio aliases defined in the ICU utility 

Radio Aliases tab.  The “All” group will also show any new radio aliases that have not yet been defined in the ICU 

Radio Aliases tab or in the Dispatch Subscriber Contacts window.  These new radio aliases might be assets you add 

to your radio system in the future.  To remove the “All” group and only show pre-defined groups from the 

Subscriber Contacts window, see the Show “All” Subscriber Group section on page 3535. 

 

Add Subscribers to the Subscribers tab as follows: 

Click Options -> Contacts.  

  -or- 

While in Edit mode, click the “Edit tab” button next to the Subscribers tab. 

 

 

 

The Subscriber Contacts window with no subscribers or groups will look like this: 

 

 

 

Add Subscriber Groups 

 

•   Creates a new Subscriber Group. 

•   Renames the selected Subscriber Group. 

•   Deletes the selected Subscriber Group. 
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Add and Configure Subscribers   

•   Creates a new Subscriber within the selected 

Subscriber Group. 

•   Deletes the selected Subscriber. 

 

 

Each Subscriber has the following settings: 

 ID: The id of the subscriber radio.  

 Type: The radio type can be a Group type or Private type. 

 Alias: The name to display in place of the radio id. 

 Assigned Channel: The assigned channel can be one of the following: 

  <Auto>: With “Auto” selected, if this radio id comes from any radio controller, this alias will be used. 

<Specific radio controller>: If a specific radio controller is selected, this alias will only be used if the 

radio id is coming from that radio controller. 

 

• Press the  button to save the changes and close the window. 

 

 

This example Subscriber Contacts window adds a “Security” section to the Subscribers tab as follows: 

 

 

The Subscriber Contacts are stored in the aliasTable.csv file.   

For more information see the Alias Table File in the Appendix on page 54. 
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Step 8. Configure other Dispatch Options 

While in Edit mode, options are available to customize the way in which RadioPro Dispatch operates.  Click on the 

Options menu, and then click Dispatch Settings to display the window shown.  Configuration options are organized 

into various folders. 

 

Note:  Following changes to any parameter, click the   button to save the changes. 

General Folder 

The General folder contains configuration options for Dispatch Users, Subscriber List, Missed Call List, History 

Logging,  Internet Proxy, Emergencies and some other items.  When the General folder is selected, the above window 

will be displayed. 

Lock Select/Unselect Channels 

Checking this box will lock Selected radio controllers (channels) on the Radio Controllers from being 

unselected. 

Hide Minimize, Maximize, and Close Application Buttons when Locked 

Checking this box will remove these buttons from the Main Window when in Lock mode. 

Recent History Items 

Choose the number of items to be displayed in the Recent History tab, from 1 to 500. 

PTT Debounce Time 

Choose a debounce time (in msec) for PTT buttons and footswitches. The range of values for this setting 

is 1 to 9999.  A typical debounce time is 200 msec. 

Replace Analog Call Aliases with the Gateway Name 

In analog radio systems, it may be more useful to display the name assigned to the IP Gateway. 

Enable Support for Elo Touch Screen Monitors 

This feature is used to change the behavior of touch events to support Elo touch screens. 

Enable Screen Capture Logging On Mouse Events 

This feature is used to debug mouse and touchscreen issues. 

 

 

 

 

Click the  button to save all Dispatch Settings. 

Note:  The configuration file for 

Dispatch Settings can be located and 

viewed by clicking on the file name 

ending with “tdcfg” 
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Dispatch Users Sub-folder 

When the Dispatch Users sub-folder is selected, the following window will be displayed. 

 

New, Delete, and Rename User Buttons 

Use these buttons to add Dispatch User Names, Delete Users, or Rename Users.  These names will be 

used to identify the “Src User” listed in the Recent History tab. 

Use the Currently Logged in Windows Account as the Dispatch user 

This feature will login the Dispatcher using the Windows login credentials. 

 

Click the  button to save all Dispatch Settings. 

 



RadioPro Dispatch Installation and Configuration Guide 

 35  

Subscriber List Sub-folder 

When the Subscriber List sub-folder is selected, the following window will be displayed. 

 

General 

Show “All” Subscriber Group 

Uncheck this box to remove the “All” group from the Subscribers tab.  With the “All” group 

removed, the list of subscribers can be limited only to predefined groups.  Groups can be set up in 

the Subscriber Contact window.  See Step 7. Add and configure Subscribers and Subscriber 

Groups on page 31. 

Make Subscribers Unavailable if Inactive for: 

A subscriber will be shown as “Unavailable” in the Subscribers tab when this time period of 

inactivity has expired. 
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Show Features 

Choose the features that should be shown in the Subscribers tab.  

These features are described in more detail in the RadioPro Dispatch 

User Guide. 

• Radio Check determines if a radio is accessible. 

• Call Alert activates the alert tone on a subscriber radio. 

• Show on map opens a new map to display the location 

of the subscriber radio 

• GPS Update forces a single GPS Trigger. 

• GPS Trigger is a feature that is useful in Capacity Max systems where the Dispatcher is 

viewing radio locations based on GPS.  This button should be used once for each subscriber 

radio that is being tracked.  This will force a GPS Trigger command to the subscriber radio, 

so that it reports its GPS position periodically.  The time period is determined by a setting in 

the GPS tab of ICU.exe. For more information, see “Minimum Poll Rate” in the RadioPro 

IP Gateway Installation Guide.  

• Remote Disable temporarily disables a remote radio. 

• Remote Enable re-enables a previously disabled radio. 

• Remote Monitor is used to remotely key-up a subscriber radio. 

• The PTT checkbox can be used to remove the PTT button from the Subscribers tab. 

PTT Action 

By default, The PTT button in the Subscriber tab is used to make private or group calls to the chosen 

Subscriber. 

 

The PTT button can be configured to use an “Audio Call” Custom Action.  After creating the custom 

action, it can be selected in the dropdown.  See Actions Folder on page 42. 

 

Radio Check Action 

By default, The Radio Check button in the Subscriber tab is used to send a message to a subscriber 

radio requesting it’s current status. 

 

The Radio Check button can be configured to use a “Radio Check” Custom Action.  After creating the 

custom action, it can be selected in the dropdown.  See Actions Folder on page 42. 

 

GPS Update Action 

By default, The GPS Update button in the Subscriber tab is used to send a message to a subscriber 

radio requesting for that radio to send it’s last GPS position. 

 

The GPS Update button can be configured to use a “GPS Update” Custom Action.  After creating the 

custom action, it can be selected in the dropdown.  See Actions Folder on page 42. 

 

Click the  button to save all Dispatch Settings. 

  

https://ctiproducts.com/documents/radiopro/v9/RadioPro%20Dispatch%20User%20Guide.pdf
https://ctiproducts.com/documents/radiopro/v9/RadioPro%20Dispatch%20User%20Guide.pdf
https://ctiproducts.com/documents/radiopro/v9/RadioPro%20IP%20Gateway%20Installation%20Guide.pdf
https://ctiproducts.com/documents/radiopro/v9/RadioPro%20IP%20Gateway%20Installation%20Guide.pdf
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Missed Call List Sub-folder 

When the Missed Call List sub-folder is selected, the following window will be displayed. 

 

Automatically remove missed call items 

When this box is checked, an item in the missed call panel will be cleared after the dispatcher responds 

to that subscriber. 

Call Button Action 

By default, The PTT button in the Missed Calls tab is used to make a private call to the chosen 

subscriber. 

 

The PTT button can be configured to use an “Audio Call” Custom Action.  After creating the custom 

action, it can be selected in the dropdown.  See Actions Folder on page 42. 

Allow Analog Calls 

With this box unchecked, analog calls will not show in the Missed Calls tab. 

Allow Digital Private Calls 

With this box unchecked, digital private calls will not show in the Missed Calls tab. 

Allow Digital Group Calls 

With this box unchecked, digital group calls and all-calls will not populate the Missed Calls tab. 

Sort Order 

• Earliest Calls First:  New calls will be added at the end of the list. 

• Latest Calls First:  New calls will be added at the top of the list. 

 

Click the  button to save all Dispatch Settings. 



RadioPro Dispatch Installation and Configuration Guide 

 38  

 

History Logging Sub-folder 

When the History Logging sub-folder is selected, the following window will be displayed. 

 

Enable Logging of events and audio 

Checking this box will enable logging of audio files and radio events to the database. 

Storage Location 

Use the    button to select a storage location for logging audio files and radio events.  This must be a 

local internal or external hard disk or SSD, and must be a different disk partition than the one used for 

the Operating System of the PC.   

 

After choosing a storage location, the “measuring disk speed…” 

window is displayed.  A test will be performed on the target 

storage location to determine if the device access speed is 

sufficient.  If the drive speed is too low, the following warning 

will be displayed. 

 

 

If this storage location has never been used as a 

RadioPro storage location, you will see this Create New 

Database window.  Click the  button to initialize 

this drive and folder location for first time use.   

 

 

Available Disk Space 

If Logging is enabled above, the available disk space is listed. 

Estimated Storage Remaining 

If Logging is enabled above, the estimated time for storing files is listed. 

Drive Speed 

If Logging is enabled above, an evaluation of the drive speed will indicate OK if satisfactory for logging. 

 

Click the  button to save all Dispatch Settings. 
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Internet Proxy Sub-folder 

When the Internet Proxy sub-folder is selected, the following window will be displayed. 

 

This window is used to define Custom Proxy settings when the following combination of requirements exist: 

• The Local Area Network uses an Internet Proxy, and  

• GPS mapping using an available Internet mapping service  

 

Click the  button to save all Dispatch Settings. 
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Emergencies Sub-folder 

When the Emergencies sub-folder is selected, the following window will be displayed. 

 

Transmit Emergency Timeout 

Use this to set the emergency timeout in seconds. 

Clearing An Emergency 

When an emergency is cleared, one of the following can be selected: 

• Remove emergency from dispatch only:  The radio with the emergency will NOT be rebooted. 

• Remove emergency and reboot radio:  The radio with the emergency will be rebooted. 

Notifications 

Use this section to choose the E-Mail and Text Alerts groups that should receive a notification when 

an Emergency is transmitted from a subscriber radio.  For more information see E-Mail & Text Alerts 

folder on page 41 

 

Click the  button to save all Dispatch Settings. 
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E-Mail & Text Alerts folder 

Geo-fence violations and Emergency conditions may be sent via email or SMS (text messaging) to any device that can 

receive these messages.  Use the E-Mail & Text Alerts 

folder to configure these messages as follows: 

1. Select the E-Mail & Text Alerts folder to display the 

window shown at right. 

2. Complete the fields in the Outgoing Server (SMTP) 

section of this window, then click the Send Test 

Email button to verify that parameters have been 

entered correctly. 

3. Click the  button to begin adding contacts 

that will receive alerts.  Each group can hold multiple 

contacts.   

4. Click the  button to add a Mobile Contact, or 

the  button to add an Email Contact. 

5. Complete the required fields for either a Mobile Contact or an Email Contact, then click the Apply button. 

Repeat steps 3 & 4 for any additional contacts. 

Note:  For any geo-fence alerts that should be sent to 

a Group of message recipients (configured using the 

steps above), be certain to enable that group in the 

Condition window of the geo-fence as shown at right.  

See Page 49 for more details about Geo-fences and 

Geo-fence Conditions. 

 

For Groups that should receive emergency alerts, be 

certain to enable that group in the Notifications 

section of the Emergencies sub folder.  For more 

information see Emergencies Sub-folder on page 40. 

 

 

 

 

 

 

Click the  button to save all Dispatch Settings. 
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Actions Folder 

When the Actions folder is selected, the following window will be displayed.   

This window is used to define specific Actions, including the following: 

• Audio calls, such as All Call, Call Selected, Tone Alert before 

• Text Messaging, such as Free-form Messaging, or Canned Messaging 

• Transmit Emergency 

• Telemetry 

• P Buttons 

• Radio Check 

• GPS Update 

• Report Problem 

Several Actions are pre-defined as indicated in the above screen capture. 

Most of the actions listed above can be associated with a Toolbar Button (using the Toolbar Buttons folder) or a USB 

PTT device (using the USB Devices folder) for use by a Dispatcher.  The Radio Check action can be configured and then 

assigned to the Radio Check button located towards the bottom of the Subscribers List. 

To create a new Action, click the  button to display the New Action Wizard.  

Select one of the options, and then click the  button.  Complete the Wizard 

prompts to create the new Action. 

Following the creation of an Action, associate the Action with an action initiator such 

as a Toolbar Button or USB PTT device. 

See the Example – Create an Action and Toolbar Button section on page 44 for more 

details on creating Actions and custom Toolbar Buttons. 

Click the  button to save all Dispatch Settings. 
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Toolbar Buttons folder 

Custom buttons may be added to the Toolbar.  When the Toolbar Buttons 

folder is selected, the window to the right will be displayed. 

 

 

 

 

 

New Button 

Click the  button to begin to create a new Toolbar 

button, and the window to the right will be displayed.   

Choose an Action from the drop-down list, rename the Button, 

and then click the  button. 

 

New Group  

Click the   button to create a button that can hold 

several nested buttons.  After a Group button has been created, select the button, and then click  to nest buttons 

under this group button.  Finally, add an action to each button. 

 

Other Options 

Clock visibility 

Choose an option from the drop-down list to show the Clock on the Toolbar. 

Mic volume visibility 

Choose an option from the drop-down list to show the Mic volume on the Toolbar. 

Select volume visibility 

Choose an option from the drop-down list to show the Select volume on the Toolbar. 

Unselect volume visibility 

Choose an option from the drop-down list to show the Unselect volume on the Toolbar. 

Quick Map button visibility 

Choose an option from the drop-down list to show the Quick Map button on the Toolbar.  This button 

will provide access to an additional map window that a Dispatcher can use for specialized needs. This 

button should be configured to be invisible for systems installations that are not equipped to handle GPS 

and Text Messaging due to data handling restrictions. 

Archive button visibility 

Choose an option from the drop-down list to show the Archive button on the Toolbar.  This button 

provides access to the Archive Viewer utility, where database searches can be performed.  The Archive 

Viewer utility can also be accessed independently by running the ArchiveViewer.exe file located on the 

RadioPro installation folder. 

Reports button visibility 

Choose an option from the drop-down list to show the Reports button on the Toolbar. This button 

provides access to the Reports utility, where summarized data can be viewed and exported.  The Reports 

utility can also be accessed independently by running the Reports.exe file located on the RadioPro 

installation folder. 



RadioPro Dispatch Installation and Configuration Guide 

 44  

Example – Create an Action and Toolbar Button for “Call Selected” 

 

1. Use the following steps to add an Action to make an Audio Call to the Selected Talk Groups.  

a. From the Actions folder in the Dispatch Settings window, click the  

button to display the Wizard’s Select a feature window shown at right.  Choose 

the Audio Call button in the above window, and then click the Next button. 

 

 

 

 

b. On Wizard’s Audio Settings window, check the box for “Wait for the channel 

to become free . . .”, and then click the Next button.  

 

 

 

 

 

 

c. On the Wizard’s Audio Tones window, choose an option to sound single or 

dual-tones before a voice call.  Duration of the tones can also be selected on this 

window.  After the tones have been selected and tested, click the Next button. 

 

 

 

 

 

d. On the Wizard’s Select a User window, choose “Default Contact for the 

selected gateway” and then click the Next button.  

 

 

 

 

 

 

e. On the Wizard’s Select Gateway’s to Use window, choose “Use the selected 

channels on the main dispatch screen”.  This selection will key-up all of the 

“Selected Channels” on the Main Dispatch window. 

 

f. Click the Finished button to return to the Actions folder of the Dispatch 
Settings window. 

 

g. Right-click on the newly created Action to rename it “Audio Call to Selected Talk Groups” as shown 

above. 
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2. Use the following steps to add a Toolbar Button to activate the “Call Selected” Action created in Step 1.  

 

a. From the Toolbar Buttons folder in the Dispatch Settings window, click the  button to display 

the following window. 

b. From the Action dropdown, select the desired Action. 

 

 
 

c. Use the  button to rename the new Toolbar Button. 

d. Rename the button as it should appear on the Toolbar. 

 

3. Click the  button to save all Dispatch Settings. 
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USB Devices Folder 

USB devices with Push-to-Talk buttons such as microphones and footswitches can be used with RadioPro.  When the 

USB Devices folder is expanded,  all available USB devices will be listed.  Each USB device will have sub-items such 

as “PTT 1” or “PTT 2”.  When a USB sub-item is selected, the windows will look like the following: 

 

Click on a USB device to view the currently programmed Action for that device.  Choose an Action from the drop-down 

list. 

Click the  button to save all Dispatch Settings. 
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GPS Folder 

The GPS folder is used for configuring GPS Map options, View Presets, Overlays, and Geo-fences.  When the GPS 

folder is selected, the following window will be displayed. 

 

Routes 

Straight Line Routes: Choose this option to show travel routes as straight lines between GPS data points.  

The travel route may not follow actual roads in this case. 

No Routes: Choose this option if travel routes should not be displayed. 

Location History 

Keep . . . minutes of location history:  Specify the length of time that Trail Crumbs should be displayed 

on the map. 

Display distance in:  Specify Miles or Kilometers. 

Subscriber Visibility 

Enable this option to show selected subscriber on map. 

Map Mode 

Choose Online Mode if this Dispatch client PC has access to the Internet.  

Choose Offline Mode if this Dispatch client PC does not have 

access to the Internet. Offline regional maps are no longer 

available for purchased.  Any maps previously purchased can 

still be used in Offline Mode.  The Offline Map may be 

imported using the  button. 

Initially Selected Map 

Choose the mapping service that will be used to initially 

display the Mapping Window  

Maps to use 

Enable any mapping services that should be accessible by the Dispatcher.  

Click the  button to save all Dispatch Settings. 
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Subscriber Licensing sub-folder 

Use the Subscriber Licensing sub-folder to add 

radio IDs that should be tracked using GPS.   

Use the  button to add a range of radio IDs 

to the tracking list. 

Use the  button to edit an entry in the 

tracking list. 

Use the  button to delete an entry from the 

tracking list. 

The remaining number of IDs on the license is indicated above the tracking list. 

Click the  button to save all Dispatch Settings. 

 

View Presets sub-folder 
When the View Presets sub-folder is selected, the following window will be displayed.   

 

Click the  button to add a new View Preset to the Toolbar of the GPS Window. 

When an existing View Preset is selected, a map will be displayed along with buttons for Deleting, Renaming, Move up, 

Move DOwn, Choosing a Map Type, and Zooming the View Preset. 

 

 

Click the  button to save all Dispatch Settings. 
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Overlays sub-folder 

When the Overlays sub-folder is selected, the following window will be displayed.  Click the  button to add 

a new Image Overlay option to the Toolbar of the GPS Window. 

 
 

When an existing Image Overlay is selected, a map will be displayed along with tool buttons for Browsing for an 

Image, Image Transparency, Choosing a Map Type, and Zooming the View Preset. 

Click the  button to save all Dispatch Settings. 

 

Geo-fences sub-folder 

One or more Geo-fences may exist in order to check various conditions of radio subscribers.  One or more conditions may 

exist for each geo-fence.  The conditions can apply to “All Subscribers” or “Specific Subscribers”.  When a Geo-fence 

condition is met for a radio subscriber, an event is logged in the database.  In addition, Geo-fence conditions that are true 

are listed in the Geo-Fence Alerts tab.  

When the Geo-fences sub-folder is selected, the following window will be displayed.   

 
A geo-fence named “Everywhere” will exist in the list of Geo-fences.  The “Everywhere” geo-fence can be used to 

check subscriber conditions regardless of where they are located.  The “Everywhere” geo-fence cannot be renamed or 

deleted from the list.  To add one or more conditions for this geo-fence, select it, and then click the  button. 
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Geo-fence Types 

Two types of geo-fences may be added to the Map.  A Polygon geo-fence is defined by three or more points, and can be 

any shape.  A Route geo-fence is defined by two points (a beginning and an end to the Route) as well as a fence width. 

Polygon Geo-fence 

A Polygon geo-fence is defined by three or more points, and can be any shape.  To add a new Polygon geo-fence 

to the map, click the  button, and the following Polygon Editing window will be displayed.   

 

Click various points on the map to create the needed Polygon geo-fence. 

 

Use the following controls on the above window to customize a Polygon geo-fence. 

Pan and Zoom 

Click and drag the mouse to Pan in any direction.  Use the Scroll Wheel to zoom in and out. 

Show Polygon 

Enable this option to display this Polygon geo-fence on the Map Window. 

Show Name 

Enable this option to display the Name of this Polygon geo-fence on the Map Window. 

Use Fence as Area Name 

Enable this option to list this Polygon name in reports instead of listing a street address for the subscriber. 

Color 

Use the  tool to choose a color and transparency for this geo-fence. 

Map Type 

Use the  tool to choose a Map Type. 

View Preset 

Use the  tool to choose a View Preset. 

Undo 

Use the  tool to remove the last added point of this Polygon geo-fence. 

Redo 

Use the  tool to redo the last removed point of this Polygon geo-fence. 
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Remove all Points 

Use the  tool to remove all points of this Polygon geo-fence. 

 

Route Geo-fence 

A Route geo-fence is defined by two or more points as well as a fence width.  To add a new Route geo-fence to the 

map, click the  button, and the following Route Editing window will be displayed.  Click points on the 

map to create the needed Route geo-fence. 

 

Use the following controls on the above window to customize a Route geo-fence. 

Pan and Zoom 

Click and drag the mouse to Pan in any direction.  Use the Scroll Wheel to zoom in and out. 

Show Route 

Enable this option to display this Route geo-fence on the Map Window. 

Show Name 

Enable this option to display the Name of this Route geo-fence on the Map Window. 

Use Fence as Area Name 

Enable this option to list this Route name in reports instead of listing a street address for the subscriber. 

Fence Width (miles) 

Use the  tool to specify a Fence Width. 

Color 

Use the  tool to choose a color and transparency for this Route geo-fence. 

Map Type 

Use the  tool to choose a Map Type. 

View Preset 

Use the  tool to choose a View Preset. 

Remove all Points 

Use the  tool to remove all points of this Route geo-fence. 

Click the  button to save all Dispatch Settings. 
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Geo-fence Conditions 

One or more Conditions may be created for any Geo-fence. Each Condition can specify details for the following 

parameters: 

• All Subscribers or Specific Subscribers 

• Subscriber is Inside or Outside the Geo-fence 

• Subscriber is traveling Over a Limit, Under a Limit, or Stopped 

• Duration of Over-speed, Under-speed, or Stopped 

 

To create a new Condition for a Geo-fence, right-click the Geo-fence, and then choose New Condition.  A window similar 

to the following will be displayed. 

 

For each condition created, choose the appropriate options: 

All Subscribers or Specific Subscribers 

Select the subscribers that this condition should be applied to this condition. 

Condition 

Create a Name for this condition, along with the condition parameters (such as speeding or entering a 

Geo-fence). 

Require Dispatcher to acknowledge 

Enable this option if a violation of this Geo-fence condition should be acknowledged by the dispatcher 

using the Geo-fence Alerts tab. 

Email and Text Alerts 

Enable one or more groups of contacts to send violations to if this Geo-fence condition. 

Click the  button to save all Dispatch Settings. 

 

The Geo-fence Alerts tab can be viewed on the Main Window.  A typical listing of Geo-fence Alerts is shown below. 

Geo-fence alerts will be saved in the data-base (if History Logging is enabled). 
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4.5 Saving the Page Layout 

To save the Page Layout discussed in the previous sections, use the following steps: 

1. Ensure that the program is in Edit mode: From the File menu, click Edit. 

2. Also from the File menu, click on Save As.  Enter a file location and file name, then click the Save button. 
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5. APPENDIX 

5.1 Configuration Files 

If a Dispatch console PC has already been configured, and it is desired to clone that configuration to additional console 

PCs, then use the Clone function described in 4.3 Configuration using Cloned Settings on Page 16. (This feature is 

available for Dispatch client version 7.0.5 and later.) 

 

Layout Configuration Files 

Two Layout Files are created when Save As is selected from the File menu: 
  yourLayoutName.xml 

  yourLayoutName.tdcfg 

These files contain information for displaying the RadioPro Dispatch client user interface screen in unique ways.  Multiple 

Layout Files may be created and used if there is a need to present different screen options.  These files may be copied to 

other PCs to duplicate a screen layout. 

Warning:  Do not attempt to edit these files! 

The location of the Layout Configuration files can be found by using the following steps: 

1. When in the Edit mode, click on the Options menu, and then choose Dispatch Settings. 

2. In the lower left-hand corner of the Dispatch Settings window, click on the file name listed that ends with 

“.tdcfg”.  A Windows file folder will be opened with the configuration file selected. 

 

Alias Table File 

A comma separated values formatted file stores a table with Alias Names, Type of Subscriber, Radio ID, and 

Assigned Radio.  This file is named: 
  AliasTable.csv 

The location for the Alias Table file can be found by using the following steps: 

1. From the Options menu, choose Contacts. 

2. In the lower left-hand corner of the Subscriber Contacts window, click on the file name listed that ends with csv.  

A Windows file folder will be opened with the configuration file selected. 

This file may be copied to other PCs to duplicate Alias names. 

Editing Alias Names using Microsoft Excel 

Microsoft Excel can be used to import or edit a large group of Subscriber radio IDs and Alias names.   

To create a list of Subscriber Radio IDs/Alias Names, use the following steps: 

1. Open the following Alias Table file using Microsoft Excel: 

Note:  The configuration file for 

Dispatch Settings can be located and 

viewed by clicking on the file name 

ending with “tdcfg” 
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For Windows 10 
 c:\ProgramData\RadioPro 

2. Edit the file with appropriate data, but do not change the 

headings in Row 1.  The file should appear as shown at 

right. 

Alias 

This column contains the Alias names to be 

associated with Subscriber radio IDs. 

(Leading spaces are not allowed.) 

Type 

This column contains the type of subscriber 

contact from the following choices. 

(Leading spaces are not allowed.): 

DIG PRI (Digital Private Subscriber) (Must be all CAPS) 

DIG GRP (Digital Group) (Must be all CAPS) 

MDC PRI (MDC Analog Private Subscriber) (Must be all CAPS) 

MCD GRP (MDC Analog Group) (Must be all CAPS) 

ID 

Radio ID of Private Subscriber or Group. (Leading spaces are not allowed.) 

Assigned Radio 

Cells in this column can be left blank for automatic (normal) channel assignment.  Alternatively, the IP 

Address of a RadioPro IP Gateway can be entered to assign the Private Subscriber or Group to a fixed 

channel. (Leading spaces are not allowed.)  

Groups 

Cells in this column contain Default or a group name to be listed in the Subscribers tab. (Leading spaces 

are not allowed.) 

Group Order 

This row defines the order of the Groups names when listed in the Subscribers tab. (Leading spaces 

are not allowed.) 

3. Save the file using “comma separated values” format.   

 

DispatchUsers.cfg File 

This text file stores user login names and is located in the same folder as the Layout Configuration files. 

Warning:  Do not attempt to edit this file! 

 

Audio Settings.cfg File 

This text file stores information about audio input and output device selection, audio levels, and cross-muting. It is located 

in the same folder as the Layout Configuration files. 

Warning:  Do not attempt to edit this file! 

License.key File 

This encrypted file stores license information allowing the RadioPro Dispatch client to connect to a maximum number of 

RadioPro IP Gateways.  It is located in the same folder as the Layout Configuration files. 

Warning:  Do not attempt to edit this file! 
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5.2 Converting a Timed-License to a Non-Expiring License 

The RadioPro IP Dispatch licenses that were shipped with this order may have a timed-license duration of 120 days.   (The 

Packing List will indicate Part # S2-61618 if the timed-license is active.)  If the Timed-License is active, and following 

the 120 day period, the RadioPro Dispatch software will not connect to a RadioPro IP Gateways.   

Following receipt of payment to CTI Products for ordered and shipped items, a request may be made to convert a timed 

license to a non-expiring license.  Use the following steps to convert the license: 

 

1. Email the Dispatch License Key serial number to support@ctiproducts.com.  The email subject line should be 

“Request for non-expiring Dispatch license”.  If you are requesting non-expiring licenses for multiple Dispatch 

licenses, list all of the License Key serial numbers. 

2. Following receipt of the updated license file from CTI Products, use RadioPro Dispatch to update the software: 

a. From the File menu, choose Edit. 

b. From the Options menu, choose Update License. 

c. In the Update License window, click the Import License Key button, and then choose the location 

where the updated license file was saved. 

d. Close the Update License window. 

e. From the File menu, choose Save. 

 

  

mailto:support@ctiproducts.com
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5.3 Telemetry (Remote I/O) Panel Configuration 

The Telemetry Panel must be configured in order to show status or provide control for I/O points located in vehicles or 

facilities. 

I/O points can be provided using the following optional hardware interfaces: 

• For vehicle I/O, a Tallysman Sprite must be connected to the mobile radio.  Features include: 

o 8 I/O points (3 inputs provided by Sprite, 5 I/O provided by radio). 

o Store-and-forward for GPS and I/O data when radio is out of RF coverage. 

o Buffering and acknowledgements by Sprite assures reliable control and status monitoring. 

o Available for MOTOTRBO (TW200) and NEXEDGE (TW202). 

o More information at: https://tallymatics.com/product/tw200/ 

 

• For facility I/O, Advantech Adam 6000 modules must be connected via IP to the Dispatch PC. Features 

include: 

o Compact, isolated I/O, economical. 

o Recommend models include: 

 ADAM-6050, 12 inputs, 6 outputs 

 ADAM-6052, 8 inputs, 8 outputs 

 ADAM-6060, 8 inputs, 6 relay form A outputs 

o More information at: https://www.advantech.com/products/ethernet-i-o-modules-adam-

6000/sub_a67f7853-013a-4b50-9b20-01798c56b090 

 

 

An example Telemetry Panel is shown in the following screenshot.   

 

The upper portion of the Telemetry Panel is a listing of configured I/O points.  

The text for each item in the list includes a description of the I/O, as well as 

its status.  In addition, the text is color-coded to indicate its status.  Select one 

of the items in the list to show more details at the bottom of the Telemetry 

Panel. 

The bottom portion of the Telemetry Panel shows detail about the selected 

I/O point in the list.  For an output, this is acts as a button to change the state 

of the I/O point. 

 

Telemetry 
Panel 

https://tallymatics.com/product/tw200/
https://www.advantech.com/products/ethernet-i-o-modules-adam-6000/sub_a67f7853-013a-4b50-9b20-01798c56b090
https://www.advantech.com/products/ethernet-i-o-modules-adam-6000/sub_a67f7853-013a-4b50-9b20-01798c56b090
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Configuring radio-based Tallysman Sprite TW2xx modules 

Use the following steps to configure a Tallysman Sprite module: 

1. Download the Sprite Configuration Utility from: 

https://ctiproducts.com/SoftwareDownloads/RadioPro/spritecfgsetup0_2_54.exe 

2. Download the Sprite Configurator User Manual from: 

https://ctiproducts.com/documents/radiopro/SpriteUserManualRev1_3.pdf 

3. Configure the Sprite TW2xx as required. 

 

Configuring Advantech Adam 6000 modules  

Use the following steps to configure Advantech Adam modules: 

1. Download the Configuration Utility from: 

https://www.advantech.com/support/details/utility?id=1-2AKUDB 

2. Run the Adam.Net utility. 

3. Search for your Adam module 

by selecting the IP address of 

the Host PC from the tree 

display then clicking the 

magnifying glass in the toolbar. 

(If the module is unused it will 

have the default IP address of 

10.0.0.1, which will need to be 

configured to have the same 

subnet as the host PC.)  The 

window shown at right will be 

displayed. 

4. Click Apply after any changes 

are made. (Default Password is 

00000000.) 

 

 

 

  

https://ctiproducts.com/SoftwareDownloads/RadioPro/spritecfgsetup0_2_54.exe
https://ctiproducts.com/documents/radiopro/SpriteUserManualRev1_3.pdf
https://www.advantech.com/support/details/utility?id=1-2AKUDB
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5. Select the IP address of your 

Adam module from the tree 

display to complete the general 

configuration of the module. 

The window shown at right will 

be displayed.  

 

 

 

 

 

 

 

 

 

 

 

 

 

 

6. After the Adam module is fully 

configured in the general 

section, you may configure the 

settings for the I/O channels by 

clicking the (+) sign located 

next to the Adam module in the 

tree display. The window 

shown at right will be 

displayed.  
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Configuring RadioPro Dispatch for the Telemetry functions 

Use the following steps to configure RadioPro Dispatch for telemetry functions: 

1. Configuration can be performed only if the program is in Edit mode.  To change to Edit mode, click on the File 

menu, and then click Edit.  (If Lock is displayed in the menu, then the RadioPro Dispatch client is already in Edit 

mode.) 

2. Click Show and select Telemetry from the drop down menu. 

3. Click on the Options menu, and then click Dispatch Settings. 

4. From the tree display under Telemetry select IO Module. 

5. When the IO Modules sub-

folder is selected, the window 

shown at right will be 

displayed. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

6. Select New Advantech, the 

window shown at right will be 

displayed. 

7. Enter the IP address you 

assigned to the Adam module in 

the Adam.Net Utility. 

8. Select the correct module type. 

(Optional: You can rename 

your new tab in the tree display 

here, by double clicking on the 

sub-folder you just created.) 

9. Click the Ping Module button. 

A successful ping notification 

should pop-up. 
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10. Select Pin Monitor & Control, 

the window shown at right will 

be displayed.  

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

11. Select Add Digital Pin Control, the 

window shown at right will be 

displayed.  

 

12. Configure these settings to your 

preference. (Optional: You can 

rename your new tab in the tree 

display here, by double clicking on 

the sub-folder you just created.) 

 

13. Click the Apply button to save all 

Dispatch Settings. 
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5.4 Using the PTT to Drive an External Signal 

An external signal can be activated whenever a call is initiated by any software or 

hardware PTT button. An additional relay module is required to interface between 

a USB port of the Dispatch PC and the external equipment to be activated.  Use 

Delcom Products model 900202 (USB G2 Dual Relay Module).  This module has 

two Form-C relays, and includes the necessary USB cable (6 ft. long).  Use the 

following link for more details, such as specifications, ordering, and datasheet: 

http://www.delcomproducts.com/ProductDetails.asp?ProductNum=900202 

This feature requires RadioPro Dispatch version 8.1.1 or later.  No other hardware or software configuration is needed.  

 

  

http://www.delcomproducts.com/ProductDetails.asp?ProductNum=900202
http://www.delcomproducts.com/ProductDetails.asp?ProductNum=900202
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5.5 Feature Availability 

Motorola MOTOTRBO Systems 

Depending on MOTOTRBO System Type, some features may not be available.  Use the following table to determine if 

a feature discussed in this document is available. 

 

System 
Type 
Feature 

Analog 
 

Convention
al Digital 

Cap + 
 

IP Site 
Connect 

Linked 
Cap + 

Connect 
Plus 

Cap Max 

Voice 
Dispatch ✓ ✓ ✓ ✓ ✓ ✓ ✓ 
Text 
Messaging  ✓ ✓ ✓ ✓ 

Not 

Currently 
Supported 

Not 

Currently 

Supporte

d 

✓ 

GPS Mapping  ✓ ✓ ✓ ✓ 
Not 

Currently 

Supported 

Not 

Currently 

Supporte

d 

✓ 

ARS  ✓ ✓ ✓ ✓ 
Not 

Currently 
Supported 

 

Private Call  ✓ ✓ ✓ ✓ ✓ ✓ 
Remote 
Monitor  ✓ ✓ ✓ ✓ ✓ ✓ 
Remote 
Enable/Disabl
e 

 ✓ ✓ ✓ ✓ ✓ ✓ 

 

 

Kenwood NEXEDGE Systems 

Depending on NEXEDGE System Type, some features may not be available.  Use the following table to determine if a 

feature discussed in this document is available. 

 

    System Type 

 

Feature 

Analog  Analog w/ 

FleetSync 

Digital 

NXDN 

Digital 

NXDN 

w/ call ack. 

  

NXDN 

& LTR 

Trunking 

NXDN 

Trunking 

(Mssg Trnkd) 

Voice Dispatch ✓ ✓ ✓ ✓ ✓ ✓ 

Text Messaging  ✓ ✓ ✓ ✓ ✓ 

GPS Mapping  ✓ ✓ ✓ ✓ ✓ 

Status Updates  ✓ ✓ ✓ ✓ ✓ 

Selective Calling  ✓ ✓ Not Currently 

Supported 
✓ 

Not Currently 

Supported 

Remote Monitor  ✓ ✓ ✓ ✓ ✓ 

Remote 

Enable/Disable 
 ✓ ✓ ✓ ✓ ✓ 
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6. DIAGNOSTICS & TROUBLESHOOTING 

6.1 Diagnostics 

ARS/GPS Event Viewer 
ARS (Subscriber Status Updates) and GPS messages arriving at an IP Gateway from the radio system can be viewed by 

using the ARS/GPS Events Viewer as follows: 

1. From the Help menu, choose ARS/GPS Events. 

2. Choose either the ARS or GPS tab to view those events. 

6.3 Troubleshooting 

Connections to IP Gateways 

RadioPro Dispatch client cannot connect to Control Station Radio 

Possible Cause 
IP connection is not possible between Dispatch client PC and RadioPro IP Gateway.  To verify, view the status of 

connections using the Manage Devices window, found under the Options menu. 

Corrective Actions 
If “Gateway not found” is indicated in the Manage Devices window, verify the following: 

1. Is IP Gateway powered up? 

2. Is IP Gateway connected to the LAN? 

3. Is data activity LED flashing on the Ethernet connector on the rear of the IP Gateway? 

4. Is the IP Address and Port listed correctly in the Manage Devices window? 

5. If Dispatch PC and IP Gateway are on the same IP Subnet, perform a “Ping” from the Dispatch PC to the IP 

Gateway in a Windows command prompt:  Does the “Ping” command from the Dispatch PC result in “Reply 

from …”? 

6. If Dispatch PC and IP Gateway are not on the same IP Subnet, has port forwarding been configured correctly 

in the connecting firewall/router?  See RadioPro IP Gateway Installation Guide; Port Forwarding, for more 

details. 

 

Possible Cause 
Connection is not possible between IP Gateway and Control Station Radio.  To verify, view the status of connections 

using the Manage Devices window, found under the Options menu. 

Corrective Actions 
If “Radio Version” is not indicated, verify the following: 

1. Is radio powered up? 

2. Is radio connected to IP Gateway as indicated in RadioPro IP Gateway Installation Guide?  

3. For a MOTOTRBO Control Station Radio, are the IP Gateway and Radio configured for different IP Subnets?  

If not, see RadioPro System Planner for IP address schemes of various radio system types. 

 

Audio 

Audio from Subscriber Radios cannot be heard at the Dispatch PC 

Possible Cause 
Control Station radio is not receiving audio from subscriber radio. 

https://ctiproducts.com/documents/radiopro/v9/RadioPro%20IP%20Gateway%20Installation%20Guide.pdf
https://ctiproducts.com/documents/radiopro/v9/RadioPro%20System%20Planner%20for%20Motorola%20MOTOTRBO.pdf
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Corrective Action 
Increase the volume level on the Control Station radio.  Is audio from a subscriber radio heard at the Control 

Station radio? If not, check radio system for causes.  If audio is heard, then continue with other Possible Causes 

listed below. 

Possible Cause 
IP Gateway is not connected to Control Station Radio. 

Corrective Action 
Ensure that radio is connected to IP Gateway’s DE-9 connector. 

Possible Cause 
Desk speakers are not turned on or the volume level is set too low. 

Corrective Action 
Turn on desk speakers and set volume level to 50%. 

 

Possible Cause 
Audio playback device such as speakers or headset is not configured and listed in the Audio Presets of the Options 

menu. 

Corrective Action 
From the Edit mode, configure Audio Presets for speakers or headset. 

 

Possible Cause 
Select or Unselect volume slider located on the Dispatch client Main Toolbar is set too low. 

Corrective Action 
Increase the Select or Unselect volume slider. 

 

Possible Cause 
Radio Controller volume slider is set to Mute. 

Corrective Action 
Un-mute the Radio Controller volume slider. 

 

Possible Cause 
The audio driver for this Radio Controller may be corrupt.  (This could be a possible cause if audio from other Radio 

Controllers can be heard.)  

Corrective Action 
From the Edit mode, delete the radio controller using: 

  Options > Manage Devices > (Select the faulty Address) > Remove. 

Then re-enter the deleted address by clicking the  button. 

 

 

Audio from Subscriber Radios are delayed by more than one second 

Possible Cause 
Audio recordings are being stored to a device with slow access, such as an external USB drive. 

Corrective Action 
Use either a second partition on the main drive, a second internal drive, an external eSATA drive, or a network 

drive.  See Section 1.3 What You Will Need on Page 10 for more details. 

 

Audio from Dispatch PC cannot be heard at the Subscriber Radios 

Possible Cause 
Microphone or headset is not connected to the Dispatch client PC. 
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Corrective Action 
Ensure that microphone or headset is connected to Dispatch client PC.  Verify that the VU meter for the 

microphone shows appropriate level when a transmission is attempted. 

 

Possible Cause 
Audio record device such as microphone or headset is not configured and listed in the Audio Presets of the Options 

menu. 

Corrective Action 
From the Edit mode, configure Audio Presets for microphone or headset. 

 

Possible Cause 
IP Gateway is not connected to Control Station Radio. 

Corrective Action 
Ensure that radio is connected to IP Gateway’s DE-9 connector. 

 

Possible Cause 
MOTOTRBO Control Station radio is not configured for Rear PC and Audio. 

Corrective Action 
Ensure that Control Station CPS setting for Cable Type in the “Accessories” folder is set for Rear PC and 

Audio. 
 

Possible Cause 
MOTOTRBO Control Station radio has Analog Mic AGC or Digital Mic AGC enabled. 

Corrective Action 
Ensure that Control Station CPS setting for “microphone” section in the “General” folder does not have Analog 

Mic AGC or Digital Mic AGC enabled.  Also verify that Analog Rear Mic Gain and Digital Rear Mic Gain are 

set to greater than +5db. 

Possible Cause 
Control Station Radio firmware is incorrect. 

Corrective Action 
Verify that radio has the minimum firmware listed in the RadioPro IP Gateway Installation Guide. 

 

Go-Ahead and Channel-Busy Tones cannot be heard at the Dispatch PC 

Possible Cause 
Desk speakers are not turned on or the volume level is set too low. 

Corrective Action 
Turn on desk speakers and set volume level to 50%. 

 

Possible Cause 
Audio playback device such as speakers or headset is not configured and listed in the Audio Presets of the Options 

menu. 

Corrective Action 
From the Edit mode, configure Audio Presets for speakers or headset. 

https://ctiproducts.com/documents/radiopro/v9/RadioPro%20IP%20Gateway%20Installation%20Guide.pdf
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Possible Cause 
Volume setting for Alert Sounds is set too low. 

Corrective Action 
While in Edit mode, from the Options menu, choose Audio Presets, click 

Config, select the Levels tab in the Audio Configuration window, adjust the 

volume level of Alert Sounds, and then click the Save button. 

 

 

 

 

Voice Playback from Recent History tab cannot be heard 

Possible Cause 
Voice files are not being recorded to the database. 

Corrective Action 
Ensure that History Logging is enabled.  This feature can be found when in the Edit mode by clicking Dispatch 

Settings under the Options menu, then choosing the History Logging folder. 

 

Possible Cause 
Desk speakers are not turned on or the volume level is set too low. 

Corrective Action 
Turn on desk speakers and set volume level to 50%. 

 

Possible Cause 
Audio playback device such as speakers or headset is not configured and listed in the Audio Presets of the Options 

menu. 

Corrective Action 
From the Edit mode, configure Audio Presets for speakers or headset. 

 

Manage Devices Window 

Times reported by IP Gateways are not synchronized 

Possible Cause 
A time server has not been configured correctly. 

Corrective Action 
See Section 2. Install Time Server on Page 13 of this document. 

 

PTT Devices 

USB PTT Device does not activate the on-screen PTT button 

Possible Cause 
PTT device is not connected to the Dispatch client PC. 

Corrective Action 
Ensure that PTT device is connected to Dispatch client PC. 

 

Possible Cause 
Dispatch client is not configured for PTT device. 

Corrective Action 
Configuration for USB PTT devices can be found when in the Edit mode by clicking Dispatch Settings under 

the Options menu, then choosing the USB Devices folder. 
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Possible Cause 
If the PTT device is Buddy DesktopMic 7G microphone, device may be configured incorrectly. 

Corrective Action 
Use MyBuddyMic utility to reconfigure the microphone using the following steps: 

1. Download the MyBuddySetup installer from: 

https://ctiproducts.com/SoftwareDownloads/RadioPro/MyBuddyMicSetup_2301292_110808.exe 

2. Use Technical Note TN204 TurboVUi Dispatch - Configuring a Buddy DesktopMic 7G.pdf to reconfigure 

the Buddy microphone. 

 

PTT Device initiates a call, but call ends abruptly after 3 seconds 

Possible Cause 
Transmit audio is not being received by RadioPro IP Gateway. 

Corrective Action 
Ensure that microphone is connected to PC, and is selected in the Audio Presets list, found in the Options 

menu. 

  

https://ctiproducts.com/SoftwareDownloads/RadioPro/MyBuddyMicSetup_2301292_110808.exe
https://ctiproducts.com/documents/radiopro/TN204ConfiguringBuddyDesktopMic7G.pdf
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7. INDEX 

A 

Actions Folder, 42 
Add Gateway, 18 
Administrator Password, 17 
Advanced tab, 23 
Advantech Adam 6000 modules, 57, 58, 59 
Alias Name, 55 
Alias Table File, 54 
AliasTable.csv, 54 
Architecture, 8 
Archive Button, 43 
Arranging Panels, 28 
ARS/GPS Event Viewer, 64 
Audio Call Custom Action, 37, 42, 44 
Audio Cross Muting, 20 
Audio Device Presets, 15 
Audio Isolate, 30 
Audio Preset, 20, 21 
Audio Quality, 20 
Audio Settings.cfg File, 55 

B 

backup gateway, 18 
Buddy DesktopMic, 68 

C 

Call Alert, 36 
Channel-Busy Tone, 22, 66 
Clock visibility, 43 
Clone settings, 16 
Compressed Mode, 20 
Configuration Files, 54 
Connected, 19 
Control Station Radio, 8 

D 

Demo mode, 10 
Devices Tab, 21 
Diagnostics, 64 
DIG GRP Digital Group, 55 
DIG PRI Digital Private Subscriber, 55 
Dispatch Settings, 33, 38, 39, 40, 41, 48 
Dispatch Users, 34 
Dispatch Users Sub-Folder, 33 
DispatchUsers.cfg File, 55 
double-click to Mute, 30 
Drive Speed, 38 

E 

Email Alerts, 41 
Emergencies Sub-folder, 33 

G 

Gateway Address, 18 
Gateway Status, 19 
Geo-fence, 47, 49, 50, 51, 52 
Geo-fence Alerts tab, 27, 52 
Geo-fence Conditions, 52 
Geo-fences Sub-folder, 49 
Go-Ahead Tone, 66 
GPS Folder, 47 
GPS Map, 47 
GPS Mapping, 11 
GPS Trigger, 36 
GPS Update, 36 
Groups, 44 

H 

High Quality Mode, 20 
History Logging, 38 
History Logging Sub-folder, 33, 39 

I 

ICU utility, 11, 18, 31, 71 
Image Overlays, 49 
Import License Key, 14, 16 
Intercom Out, 21 
Internet Proxy, 39 
Internet Proxy Sub-folder, 33 
IO Module, 60 
IP Gateway, 8, 14, 15, 18, 19, 22, 55, 71 

L 

Levels Tab, 22 
License 

Import, 16 
Update, 16 

License file, 10 
License File, 14 
License.key File, 55 
Lock, 15 

M 

Manage Devices Window, 18 
Manage IP Gateways, 18 
MDC GRP MDC Analog Group, 55 
MDC PRI MDC Analog Private Subscriber, 55 
Messages tab, 27 
Mic volume, 43 
Mic-In, 21 
Missed Call List, 37 
Missed Call List Sub-folder, 33 
Missed Calls tab, 27 
Mouse Events, 33 
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Mute audio when transmitting, 20 

N 

Non-Expiring License, 56 
NTP Server, 71 

O 

Offline Maps, 47 
Overlays Sub-folder, 49 
Overview, 5 

P 

Patch, 30 
PC cross mute, 20 
PC hibernate, 11 
Polygon geo-fence, 50 
PTT Debounce, 33 

Q 

Quick Map, 43 

R 

Radio Check, 36 
Radio Controller Panel, 29, 30 
Radio version, 11 
Radio Version, 19 
RadioPro Solo™ client software, 6 
RadioPro Talk™ mobile client software, 6 
RadioPro™ IP Gateway, 5 
Recent History tab, 27, 33, 34, 67 
Remote Disable, 36 
Remote Enable, 36 
Remote Monitor, 36 
Reports Button, 43 
Route Geo-fence, 51 
RSSI, 30 

S 

Saving the Page Layout, 53 
Secondary Address, 18 
Select Out, 21 

Select volume, 43 
Subscriber Contacts, 31 
Subscriber Licensing, 48 
Subscriber List, 35 
Subscriber List Sub-folder, 33 
Subscriber Visibility, 47 
Subscribers tab, 27, 31, 35, 36 
System Planner, 11 
System Planner Template, 71, 72 

T 

Tab Anchor Points, 28 
Talk-Permit Tone, 22 
Tallysman Sprite, 57, 58 
tdcfg Files, 54 
Telemetry functions, 60 
Telemetry Panel, 57 
Telemetry tab, 27 
Text Alerts, 41 
Time Server, 13 
Timed-License, 56 
Toolbar, 42 
Toolbar Buttons, custom, 42 
Touch Screen, 12, 33 
Trail Crumbs, 47 
Troubleshooting, 64 

U 

Unselect Out, 21 
Unselect volume, 43 
USB flash drive, 10, 14 
USB G2 Dual Relay, 62 
Use Fence as Area Name, 50, 51 

V 

Version match, 11 
View Presets Sub-folder, 48 
Voice and Event Logging, 38 
Volume Adjustments 

Alert Sounds, 22 
Intercom Volume, 22 
Mic Volume, 22 
Select Receive, 21, 22, 29 
Unselect Receive, 21, 22 
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8. SYSTEM PLANNER TEMPLATE PAGE 1 OF 2 

RadioPro IP Gateways 

See RadioPro IP Gateway Installation Guide for more information. 

Parameters Common to all IP Gateways 

ICU.exe Admin Password 
for ICU.exe, default is “admin” 

Dispatch Client Password 
for Dispatch client connections 

default is “user” 

NTP Server IP Address 
Network Time Protocol 

   

 

Parameters Unique to Each IP Gateway 
GPS = GPS Data Revert. 

Each IP Gateway supports 1 
Voice & 1 GPS Data Radio. 

Name 
IP Gateway name has max 2 

lines, 24 chars per line 

Serial 
# 

IP Address Subnet Mask 
Default 

Gateway 

IP Gateway A Example Gateway Name 1234 192.168.56.22 255.255.255.0 192.168.56.1 

Voice Radio A0 Example Radio VR A0  192.168.10.1 255.255.255.0  

GPS Radio A1 Example Radio GPS A1  192.168.11.1 255.255.255.0  

IP Gateway B      

Voice Radio B0      

GPS Radio B1      

IP Gateway C      

Voice Radio C0      

GPS Radio C1      

IP Gateway D      

Voice Radio D0      

GPS Radio D1      

IP Gateway E      

Voice Radio D0      

GPS Radio D1      

IP Gateway F      

Voice Radio D0      

GPS Radio D1      

IP Gateway G      

Voice Radio D0      

GPS Radio D1      

IP Gateway H      

Voice Radio D0      

GPS Radio D1      

IP Gateway J      

Voice Radio E0      

GPS Radio E1      

If additional IP Gateways are needed, copy this page. 

See next page for System Planner Template Page 2 of 2 

https://ctiproducts.com/documents/radiopro/v9/RadioPro%20IP%20Gateway%20Installation%20Guide.pdf
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9. SYSTEM PLANNER TEMPLATE PAGE 2 OF 2 

RadioPro Dispatch Clients 

 

Parameters Common Parameters Unique 
to all Dispatch clients to all Dispatch clients 

Administrator Password 
for Edit Mode 

 PC Name 
 

IP Address 
 

License 
Serial # 

Licensed IP Gateway 
Connections 

      

      

      

      

      

      

      

      

RadioPro Solo, Talk, and Talk Mobile Clients 

See the RadioPro Solo Installation Guide for more information. 

The following parameters are configured in the IP Gateway using ICU.exe. 

Parameters Common to all Talk Clients 

Administrator Login Name 
Not Editable 

Administrator Password 
default is “admin” 

admin  

 

User Login Name 
default is “user” 

User Password 
default is “user” 

  

  

  

  

  

  

  

  

  

  

If additional Solo, Talk or Talk Mobile client logins are needed, copy this page. 

https://ctiproducts.com/documents/radiopro/v9/RadioPro%20Solo%20Client%20Installation%20Guide.pdf

